[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: boot loader not installing for encrypted 64-bit

From: Kete
Subject: Re: boot loader not installing for encrypted 64-bit
Date: Sat, 22 Feb 2020 20:25:28 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Icedove/60.9.0

Ok, I tried running that grub-install command manually, making the
--efi-directory /mnt/boot/efi, but I got the same error. Then, I made an
efi directory in /mnt/boot, and grub-install replied something like,
"That doesn't look like an EFI partition!" Next, I decided not to make
an EFI partition and to change my config to grub-bootloader with target
"/dev/sda", and I ran the system init. Guix built a few derivations and
slowly copied a massive number of files to /mnt. Finally, it said the
bootloader was successfully installed. That worked, but I had to disable
UEFI boot and enable "legacy" boot in the BIOS.

On 2/22/20 7:23 PM, Kete via wrote:
> They don't look wrong, but here are the contents of /sys/firmware/efi:
> config_table, efivars/, esrt/, fw_platform_size, fw_vendor, runtime,
> runtime-map/, systab, vars/
> and here is my config.scm:
> ;; This is an operating system configuration generated
> ;; by the graphical installer.
> (use-modules (gnu))
> (use-service-modules desktop networking ssh xorg)
> (operating-system
>   (locale "en_US.utf8")
>   (timezone "America/New_York")
>   (keyboard-layout
>     (keyboard-layout "us" "colemak"))
>   (bootloader
>     (bootloader-configuration
>       (bootloader grub-efi-bootloader)
>       (target "/boot/efi")
>       (keyboard-layout keyboard-layout)))
>   (mapped-devices
>     (list (mapped-device
>             (source
>               (uuid "e1a31f72-4787-44f3-80dd-5be064aed1bc"))
>             (target "cryptroot")
>             (type luks-device-mapping))))
>   (file-systems
>     (cons* (file-system
>              (mount-point "/")
>              (device "/dev/mapper/cryptroot")
>              (type "ext4")
>              (dependencies mapped-devices))
>            %base-file-systems))
>   (host-name "ketesguix")
>   (users (cons* (user-account
>                   (name "kete")
>                   (comment "Kete")
>                   (group "users")
>                   (home-directory "/home/kete")
>                   (supplementary-groups
>                     '("wheel" "netdev" "audio" "video")))
>                 %base-user-accounts))
>   (packages
>     (append
>       (list (specification->package "nss-certs"))
>       %base-packages))
>   (services
>     (append
>       (list (service mate-desktop-service-type)
>             (service openssh-service-type)
>             (service tor-service-type)
>             (set-xorg-configuration
>               (xorg-configuration
>                 (keyboard-layout keyboard-layout))))
>       %desktop-services)))
> On 2/22/20 6:19 PM, Kete via wrote:
>> PS – Here is the output:
>> error: '/gnu/store/...-grub-efi-2.02/sbin/grub-install --boot-directory
>> /mnt/boot --bootloader-id=Guix --efi-directory /boot/efi' exited with
>> status 1; output follows:
>>     Installing for x86_64-efi platform.
>>     /gnu/store/...-grub-efi-2.02/sbin/grub-install: error: failed to get
>> canonical path of '/boot/efi'.
>> guix system: error: failed to install bootloader
>> /gnu/store/...-bootloader-installer
>> On 2/22/20 5:42 PM, Kete via wrote:
>>> Hello,
>>> I've tried to install an encrypted GuixSD 64-bit on 2 different
>>> computers, and both times, the graphical install couldn't install the
>>> bootloader. In Qemu and on 32-bit, the bootloader installed fine. I
>>> don't know how to fix. There's an efi directory on the flashdrive, so I
>>> don't know what's going wrong. I have rebooted, decrypted and mounted my
>>> partition, turned on the swap file, set the cow-store to /mnt, and
>>> restarted the system init, and it looks like it's downloading the
>>> packages, again.
>>> Kete

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]