[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: `guix pull` fails after fresh install

From: Gabriel Wicki
Subject: Re: `guix pull` fails after fresh install
Date: Fri, 20 Aug 2021 01:00:56 +0200

Please ignore my previous message in this thread, i sent the wrong
version...  Here's the right one:

I was able to fix it! Yay

Because this mailing list is a resource for people seeking help I'll
hereby take the liberty to document how I tracked the issue down and
fixed it.

I added a new user to find out if the problem was reproducible and
whether the system was to blame.  This was luckily not the case.
`guix pull` worked for the freshly added user 'test'.  But I found
the following differences: both




were real directories, whereas for the new 'test' user at the
corresponding paths there were symlinks: the former pointing to
current-guix-1-link in the same directory while the latter pointed to
the former.  Also, there is no file called `current-guix-0-link` in
/var/guix/profiles/per-user/user/, but `current-guix` in the same
directory points to that.  I guessed this was most probably causing
the issue.

If I understand correctly guix stores two kinds of of symlinks in
user-profiles (which live in /var/guix/profiles/per-user/):

  1. current-guix-N-link: links to guix profiles (which contain guix
and guix-daemon executables and info files),

  2. guix-profile-N-link: links to package profile generations
(which contain all installed programs including libraries,
executables and documentation)

  and for each of those link-types one special link (current-guix and
guix-profile) pointing to the currently active one of their kind.

My guix-profile links seemed to be fine, but my suspicion grew that
I'd have to replace the aforementioned directories with symlinks to 
the right places.  Only problem: I did't know which is the "right"
current-guix profile to link to.  But since my installation is just
some days old I figured there shouldn't be too much of a difference
between the different guix versions on my machine and just linked to
the one which
pointed to.

I tested with `guix pull` which worked just fine.  Pleased with the
outcome I happily `guix package upgrade`d my profile.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]