[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Guix on a cloud VM

From: Ben Sturmfels
Subject: Guix on a cloud VM
Date: Tue, 31 Aug 2021 12:40:33 +1000
User-agent: mu4e 1.6.5; emacs 27.2

Hi Mathieu (and CC'ing help-guix),

Thanks for your help on the Guix IRC yesterday! I'm still struggling
with getting the VM running as I'd like. I tried the ISO format as you
suggested, but my hosting service (Binary Lane) seems to treat this
somewhat-specially as a read-only format. I can "trick" it into
restoring from this image using their "clone" feature though. The
machine boots up fine but the result seems to be a read-only Guix where
/etc/fstab shows an iso9660 filesystem.

Backing up a little for context, I've tried qcow2 format which is lovely
and small, but fails to boot on my hosting service with "No bootable

I've also tried efi-raw which boots and runs smoothly, but fails to
resize later on my hosting service. (Resize is required because
otherwise I literally have to generate and upload a 20GB image.) I
suspect (but don't know for sure) that this is related to the additional
40M EFI partition created in the image before the root EXT4 partition.
The images provided by my hosting service only have a single EXT4
partition eg. Debian 10.

Do you know if it's possible to get `guix system image` to skip the EFI
partition when creating an efi-raw image?

A couple of other questions too:

Does the process in your blog post work for you if you go straight to
QCOW2 with `--image-type=QCOW2` rather than converting the efi-raw to

Are you able to later resize the storage via your DigitalOcean control
panel? This operation is failing for me currently.

Thanks again for your help and excellent blog post!


Reference for anyone else reading:

Mathieu's blog post:

My work-in-progress guix deploy experiments:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]