[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Issues with CUPS

From: Tobias Geerinckx-Rice
Subject: Re: Issues with CUPS
Date: Sat, 04 Dec 2021 11:57:01 +0100


Alexander Asteroth 写道:
- Which PPD file did you import?  Was it[0]?  If not, try that.

I have no idea what it[0] is.

This is about to become amusingly confusing, because I'm in turn not sure what ‘it[0]’ refers to above.

If you mean the ‘[0]’: there was a link at the bottom of my mail to the PPD I tried.

If you mean the file itself: it's what this form[1] (another link below :-) produces from selecting your printer model and clicking ‘Generate PPD file’.

I did not inspect how that site works, but as modern CUPS autogenerates .ppd files from .drv files, I expect it to do the same.

The ppd I used before is from the Samsung uld-package

That's the binary-only (and hence unsupportable) .deb, right?

- Why remove foomatic-filters from the default CUPS extensions list?

I was not aware that adding filters to the service description overrides the filters default values. I thought it just add's them and somewhere
it was remommended adding the hplib-minimal filters, and in my
helplessness I tried everything ;-)

Wait, so it didn't work with the default list?  :-(

Also, was it not clear from the Guix manual that the default list should include all viable drivers? If you have any suggestions to improve the wording, please let me know!

Anyway, I gave other Samsung drivers a try and with the SCX-5330N I found a
driver that also seems to work with my SCX-4729.

Great!  All's well that ends well.

I find it strange that the foomatic package doesn't offer you exact printer model when it probably supports it, but that's not really a Guix bug, I think.

Happy printing,



Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]