[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: valgrind error

From: Abhiseck Paira
Subject: Re: valgrind error
Date: Tue, 08 Mar 2022 18:12:25 +0530

I am sorry :-(, it seems the issue is answered already[1], when I searched
the mailing list with "valgrind" as the keyword it wasn't returned.

Abhiseck Paira <> writes:

> Hi,
> I am trying to learn C and according to the instruction I'm following
> when I run:
> $ valgrind ./hello-world.o
> I get the following error:
> --------------
> $ valgrind ./hello-world.o
> ==4074== Memcheck, a memory error detector
> ==4074== Copyright (C) 2002-2017, and GNU GPL'd, by Julian Seward et al.
> ==4074== Using Valgrind-3.18.1 and LibVEX; rerun with -h for copyright info
> ==4074== Command: ./hello-world.o
> ==4074== 
> valgrind:  Fatal error at startup: a function redirection
> valgrind:  which is mandatory for this platform-tool combination
> valgrind:  cannot be set up.  Details of the redirection are:
> valgrind:  
> valgrind:  A must-be-redirected function
> valgrind:  whose name matches the pattern:      strlen
> valgrind:  in an object with soname matching:
> valgrind:  was not found whilst processing
> valgrind:  symbols from the object with soname:
> valgrind:  
> valgrind:  Possible fixes: (1, short term): install glibc's debuginfo
> valgrind:  package on this machine.  (2, longer term): ask the packagers
> valgrind:  for your Linux distribution to please in future ship a non-
> valgrind:  stripped (or whatever the dynamic linker .so is called)
> valgrind:  that exports the above-named function using the standard
> valgrind:  calling conventions for this platform.  The package you need
> valgrind:  to install for fix (1) is called
> valgrind:  
> valgrind:    On Debian, Ubuntu:                 libc6-dbg
> valgrind:    On SuSE, openSuSE, Fedora, RHEL:   glibc-debuginfo
> valgrind:  
> valgrind:  Note that if you are debugging a 32 bit process on a
> valgrind:  64 bit system, you will need a corresponding 32 bit debuginfo
> valgrind:  package (e.g. libc6-dbg:i386).
> valgrind:  
> valgrind:  Cannot continue -- exiting now.  Sorry.
> ---------------
> I tried logging out/logging in but it didn't work, I have installed
> "gcc-toolchain" and "gdb" packages, am I missing something else?

Abhiseck Paira
E34E 825B 979E EB9F 8505  F80E E93D 353B 7740 0709

reply via email to

[Prev in Thread] Current Thread [Next in Thread]