[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[solved] Geiser (or ielm) in Emacs doesn't return the prompt

From: Maxim Cournoyer
Subject: [solved] Geiser (or ielm) in Emacs doesn't return the prompt
Date: Wed, 18 Jan 2023 16:22:12 -0500

Hi Guix,

I've spent some time today trying to understand why my setup had stopped
working, with the following symptoms:

1.  Evaluating anything in Geiser (wih Guile) would not return the
prompt, seemingly hanging.

2. The same in IELM (M-x ielm), an Elisp REPL builtin Emacs

It ended up being due to changes in Paredit 25 and up.  The author
currently recommends disabling the electric-indent-mode, or overriding
the following mode map keys:

(define-key paredit-mode-map (kbd "RET") nil)
(define-key paredit-mode-map (kbd "C-j") 'paredit-newline)

I've used the later, and my setup now works as it used to!

I hope this can save some time for anyone else affected.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]