[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: OBS Studio memory leak

From: Ott Joon
Subject: Re: OBS Studio memory leak
Date: Tue, 13 Jun 2023 10:05:25 +0200 (CEST)


Tried the same thing in VLC and it freezes on GPU accel and starts leaking 
memory while also becoming hard to kill.
Maybe this also explains why some mpv GPU accel settings don't work also in the 
exact same way.
I have an AMD RX 6900 XT on this machine.

I could probably try this on the laptop with Intel and the unmentionable video 

PS: Might need to switch to a traditional email service or get my own up and 
running. Tutanota is just no good for this mailing list stuff.

13. juuni 2023 10:50 poolt

> Robby Zambito <> skribis:
>> Ott Joon <> writes:
>>> Hey there
>>> I have the exact same issue and I think this has to do with
>>> gstreamer. Some other programs are also affected by this bug. What
>>> seems to happen is the gst-plugin-scanner starts searching for plugins
>>> and just doesn't finish and leaks memory a ton. My 128GB of RAM will
>>> be full in seconds if I launch anything that uses gstreamer. Even
>>> virt-manager if you have gst-plugin-* packages installed as then the
>>> gst-plugin-scanner is awakened. I had to remove them or unset
>>> GST_PLUGIN_SYSTEM_PATH. Unfortunately OBS seems to have this feature
>>> built in, so it's not something you can remove. This is all I know at
>>> the moment.
>>> Ott
>> Hi Ott,
>> Thanks for the lead. I tried pinning gstreamer and gst-plugins-base to
>> older versions available in Guix, and removing gst-plugins-base from
>> being an input to OBS (though I'm not positive this removes it from all
>> recursive inputs), but I'm still having the issue :(
>> Here is what I have so far:
>> (let ((parent (specification->package "obs")))
>> (package
>> (inherit parent)
>> (inputs (modify-inputs (package-inputs parent)
>> (replace "gstreamer"
>> ((options->transformation '((with-version . "gstreamer=1.20.3")))
>> (specification->package "gstreamer")))
>> (replace "gst-plugins-base"
>> ((options->transformation '((with-version . "gst-plugins-base=1.20.3")))
>> (specification->package "gst-plugins-base")))))))
>> Also tried with (remove "gst-plugins-base") instead of the replace.
>> Robby
> Hi,
> I don't know if its related, but I have a big memory leak issue with
> vlc. When trying to play a video with it, if the video output module it
> set to gl or vdpau_display, it consumes all the RAM of the machine in
> a few seconds (and I have to kill it fast to prevent the machine from
> hanging). However if I force the video output module to xcb_xv, it works
> fine.
> Do you have the same issue with vlc? If yes, it may indicate a bug
> with video acceleration (VA-API/VDPAU or mesa).
> PS: My machine's GPU is an AMD Radeon RX 6800 XT.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]