[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Wojtek Kosior
Subject: Re:
Date: Tue, 18 Jul 2023 17:27:20 +0200

Hi there,

AFAIK there's no stable branch of Guix.

Please share the code of your Guix system configuration and the exact
error message you received.

I'd normally expect efibootmgr errors when trying to install a UEFI
variant of GRUB while being booted in legacy mode. So you can first
make sure your USB is booted in UEFI mode before trying to install a
UEFI GRUB. Alternatively, you can install the OS in legacy mode (i.e.
without using ESP) and then set your laptop to boot from disk in legacy
mode. Please look into Guix documentation to find information on how to
perform both types of installation


-- (sig_start)
fingerprint: E972 7060 E3C5 637C 8A4F  4B42 4BC5 221C 5A79 FD1A
follow me on Fediverse:

♥ R29kIGlzIHRoZXJlIGFuZCBsb3ZlcyBtZQ== | ÷ c2luIHNlcGFyYXRlZCBtZSBmcm9tIEhpbQ==
✝ YnV0IEplc3VzIGRpZWQgdG8gc2F2ZSBtZQ== | ? U2hhbGwgSSBiZWNvbWUgSGlzIGZyaWVuZD8=
-- (sig_end)

On Tue, 18 Jul 2023 13:13:18 +0300 Dr. Ibrahim Y. EL-Nahhal 
<> wrote:

> Hash: SHA256
> Dear Guix Community,
> I am writing to report an issue that I encountered while updating my GNU Guix 
> System Distribution. I was able to successfully install it on my laptop, but 
> when I ran "guix pull" and "guix system reconfigure", the updating process 
> failed to install the bootloader on my ESP partition. As a result, when I 
> rebooted my laptop, I couldn't boot normally to my GNU Guix System and no 
> GRUB bootloader was found.
> I tried to create a new USB stick for the installation of GNU Guix, and the 
> installation proceeded well except for the last step which was the 
> installation of the bootloader. I received a message about efibootmgr. 
> Eventually, I switched to the installation of my NixOS Linux and successfully 
> installed it on my HP laptop from which I am reporting this issue to the Guix 
> community.
> I would like to know if there is a stable branch for Guix in the same way as 
> there is a stable branch of NixOS Linux. Also, I would appreciate any help or 
> guidance on how to solve the above issue.
> Thank you for your time and assistance.
> Best regards,
> - -- 
> Dr. Ibrahim Y. EL-Nahhal
> iQJJBAEBCAAzFiEEyz6U+Z8D5ICywdWs+5Wblsm+zXQFAmS2ZcsVHGVsbmFoaGFs
> LmlAZ21haWwuY29tAAoJEPuVm5bJvs10eA8P/Aro7Mf3BCBXYHDL4IeL7q9pY/KB
> UdZqCtCU5hm1vCx1lfyvqZjLKOj2ylySaUIywKARgKwL1P31QZ5y5h/b2IqzoZcQ
> 2hY/YAWHWWC9bsIB7zd8EAUWGsYe4NcuPmcTUp4oP77cXdd79wZK3cwfR+/4+8vE
> 8Q0QqmuSaYnKsY9XqK1hsIqpO6Rh6PKo22XQOvuSbYCRYJtEesMsXZeKOa39I4q+
> +gFFiRBWzH79PQjPJM53yCyDFzxGZGZP/9/qRUiw1hE2nlKX5uj/iIROm7W/7GGU
> NX0x9cgzkrMJzwj/V0t8Z1StGYB5AZgopsUxz60NCE4SS0izy/Gav3oPHkuhKGm4
> ICLEGrkoMEnmqlQ4eM2X3hnM6dc5rjpr8lQfrbXsy0N0NW+qDoGy3/nm+7tNEIBm
> n8Z21g67wnYn7d+oIDzHkgwYVh4Ij7RYM9UStMjgcfnoqizuGyXMHbojfbuhUlKL
> NID0FSExXbM2pZq/Gfap3gz33A2k9Cgy1E8/kqxorVokzVFu+kTaQW9KL2XtCYIN
> a4m7FIJbGhtix5RsPOODMMZnbeszyjuCzvVnlMJPc8xOZsb3SUcdd+dcPQnK9f49
> bv2pEmJMGqK8/TtTlJW9nyDFTJbw8sO/m+eiML5trl5YgkJ79GfoANhNN0b4yHzW
> 2kSfFVnrsMKVYph9
> =WiXQ

Attachment: pgph3WKKgEyG1.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]