[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ibus + ibus-libpinyin in Gnome

From: Luis Felipe
Subject: Re: ibus + ibus-libpinyin in Gnome
Date: Wed, 19 Jul 2023 12:42:44 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.12.0

Hi Ricardo,

El 18/07/23 a las 21:14, Ricardo Wurmus escribió:
Hi Guix,

I’m still struggling with ibus + ibus-libpinyin on Gnome.
ibus-libpinyin works in the gnome-shell input field, but the input
method doesn’t work in any of the applications such as icecat, console,
or soffice.

Surprisingly, it works for me (I haven't been able to type Japanese for months). I tried in icecat and console.

The GTK_IM_MODULE environment variable is set to “ibus”.  I export it in
the shell and launch “soffice” or “icecat” from there.

Hmm, I don't have GTK_IM_MODULE set in my ~/.profile (don't remember why I removed it...). I have these:

# export GUIX_GTK2_IM_MODULE_FILE="$HOME/.guix-profile/lib/gtk-2.0/2.10.0/immodules-gtk2.cache" export GUIX_GTK3_IM_MODULE_FILE="$HOME/.guix-profile/lib/gtk-3.0/3.0.0/immodules-gtk3.cache"
# These are needed only to work on Qt apps like TeXmacs.
export XMODIFIERS="@im=ibus"  # Set X input method server (xim) to ibus.
export QT_IM_MODULE="ibus"    # Set Qt input method module to ibus.

ibus and ibus-libpinyin are installed in the system profile as well as
the user profile.  I previously had installed them only in the user
profile, but then added them to the system profile because I want to be
sure that any required environment variables are set in all contexts,
even when launching applications from the Gnome shell.

I install ibus engines in my profile. I tried installing them in the system profile, and that never worked for me. But I haven't tried recently.

Do you have any ideas how to best debug this?  I could strace the
applications and see if any of them mention a failure to talk to ibus,
but I’d like to avoid having to sift through all that noisy trace output
for massive GTK applications.

For what it's worth, I was suggested to run the engine directly when I was having trouble with ibus-stt ( So maybe

/gnu/store/1s0p8fk1bgp0v2gv5dgjgpq1v4p3nwji-ibus-libpinyin-1.15.2/libexec/ibus-engine-libpinyin --gapplication-replace -g

That helped me fix some ibus-stt errors. (And actually, I see an error when running the ibus-anthy engine, which might be why I can't even find the engine listed in input options).

Good luck,

Luis Felipe López Acevedo

Attachment: OpenPGP_0x0AB0D067012F08C3.asc
Description: OpenPGP public key

Attachment: OpenPGP_signature
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]