[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

URISyntaxException building openjdk@10

From: Greg Hogan
Subject: URISyntaxException building openjdk@10
Date: Thu, 20 Jul 2023 11:32:40 -0400

Hi Guix,

I have tried everything I could think of but have been unable to build
openjdk@10 since the final core-updates merge. Am simply running `guix
build openjdk` from a recent `guix pull`.

`/tmp` is mounted `tmpfs` but I have also tried keeping tmp on the
root filesystem (AWS Linux 2023 defaults to xfs, have also tried the
same with Amazon Linux 2). Same result with an ARM instance.

Has anyone else come across this issue? Or have any ideas to try?

--8<---------------cut here---------------start------------->8---
$ guix describe
Generation 3    Jul 11 2023 19:36:46    (current)
  guix 15f9870
    repository URL:
    branch: master
    commit: 15f9870eb36e688fac2af37828971779b6c56916
--8<---------------cut here---------------end--------------->8---

Build log attached. The end of the log file:

--8<---------------cut here---------------start------------->8---
Compiling 4 files for BUILD_JIGSAW_TOOLS
Error occurred during initialization of boot layer
Caused by: Illegal character in path at
index 32: 
make[3]: *** [ExplodedImageOptimize.gmk:41:
Error 1
make[2]: *** [make/Main.gmk:361: exploded-image-optimize] Error 2

ERROR: Build failed for target 'all' in configuration
'linux-x86_64-normal-server-release' (exit code 2)
Stopping sjavac server

No indication of failed target found.
Hint: Try searching the build log for '] Error'.
Hint: See doc/building.html#troubleshooting for assistance.

make[1]: *** [/tmp/guix-build-openjdk-10.46.drv-0/source/make/Init.gmk:296:
main] Error 2
make: *** [/tmp/guix-build-openjdk-10.46.drv-0/source/make/Init.gmk:186:
all] Error 2
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("JOBS=2" "all")
exit-status: 2 term-signal: #f stop-signal: #f>
phase `build' failed after 1189.8 seconds
command "make" "JOBS=2" "all" failed with status 2
--8<---------------cut here---------------end--------------->8---


Attachment: av90lwnifaajapw65zcg95aqw0daga-openjdk-10.46.drv.gz
Description: application/gzip

reply via email to

[Prev in Thread] Current Thread [Next in Thread]