[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

problem trying to install python module in python virtual environment on

From: Andy Tai
Subject: problem trying to install python module in python virtual environment on top of Guix
Date: Sat, 12 Aug 2023 15:39:16 -0700

Hi, on a Guix system I tried to install python dependencies in a
python virtual environment.   I installed Guix packages
python-toolchain and python-virtualenv, and use the basic python
commands virtualenv and pip3 to go ahead and install dependencies in a
typical python manner.

I got one error in a dependencies that tried to build C modules which
involves using cmake in this python environment: (not the system cmake
but something python stuff installed as part of its process):

Building wheels for collected packages: llama-cpp-python
  Building wheel for llama-cpp-python (pyproject.toml) ... error
  error: subprocess-exited-with-error

  × Building wheel for llama-cpp-python (pyproject.toml) did not run
  │ exit code: 1
  ╰─> [9 lines of output]
      Traceback (most recent call last):
line 645, in setup
          cmkr = cmaker.CMaker(cmake_executable)
line 148, in __init__
          self.cmake_version = get_cmake_version(self.cmake_executable)
line 105, in get_cmake_version
          raise SKBuildError(msg) from err

      Problem with the CMake installation, aborting build. CMake
executable is 
      [end of output]

  note: This error originates from a subprocess, and is likely not a
problem with pip.
  ERROR: Failed building wheel for llama-cpp-python
Failed to build llama-cpp-python
ERROR: Could not build wheels for llama-cpp-python, which is required
to install pyproject.toml-based projects

[notice] A new release of pip is available: 23.1.2 -> 23.2.1
[notice] To update, run: pip install --upgrade pip

wonders if anyone knows if the above can be attempted on top of Guix;
not sure if the C build environment can be seen properly under Python

Also the Python tools packaged in Guix seem rather old, and tat can be
part of the issue here.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]