[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Trying to understand why GUIX isn't reading configuration file?

From: Patrick Pippen
Subject: Trying to understand why GUIX isn't reading configuration file?
Date: Sun, 13 Aug 2023 08:20:45 -0500

Previously what I thought was a gdm issue, upon further investigation I
believe this to be a guix issue or my lack of understanding guix way of
doing things.
My current issue is after installing guix with a guided installation. I
preceded to install bspwm as a user, what is happening is
I created a .xsession file and chmod +x ~/.xsession with the following

sxhkd -c $HOME/.config/sxhkd/sxhkdrc &
polybar -c $HOME/.config/polybar/config &
exec bspwm -c $HOME/.config/bspwm/bspwmrc

At first I've tried: exec bspwm
And it still doesn't work.

The issue that I'm not understanding is the bspwmrc file isn't being read
after logging in so I have to open a terminal and do this.

source $HOME/.config/bspwm/bspwmrc

Looking at my config.scm file, I've noticed that services-type-desktop only
shows XFCE. How can I get bspwm added to this file?
Or is there a way to get bspmwmrc file read automatically?

At the login screen, although XFCE and BSPWM are both installed there is
only a login prompt. To run XFCE I have to remove the ~/.xsession file.
XFCE was installed during installation of GUIX, after install as regular
user I install BSPWM.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]