[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Trying to understand why GUIX isn't reading configuration file?

From: 宋文武
Subject: Re: Trying to understand why GUIX isn't reading configuration file?
Date: Mon, 14 Aug 2023 18:02:02 +0800
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.2 (gnu/linux)

Patrick Pippen <> writes:

> Previously what I thought was a gdm issue, upon further investigation I
> believe this to be a guix issue or my lack of understanding guix way of
> doing things.
> My current issue is after installing guix with a guided installation. I
> preceded to install bspwm as a user, what is happening is
> I created a .xsession file and chmod +x ~/.xsession with the following
> content:
> sxhkd -c $HOME/.config/sxhkd/sxhkdrc &
> polybar -c $HOME/.config/polybar/config &
> exec bspwm -c $HOME/.config/bspwm/bspwmrc

make sure it start with a shebang line, which should be:

sxhkd -c $HOME/.config/sxhkd/sxhkdrc &
polybar -c $HOME/.config/polybar/config &
exec bspwm -c $HOME/.config/bspwm/bspwmrc

> At first I've tried: exec bspwm
> And it still doesn't work.
> The issue that I'm not understanding is the bspwmrc file isn't being read
> after logging in so I have to open a terminal and do this.
> source $HOME/.config/bspwm/bspwmrc
> Looking at my config.scm file, I've noticed that services-type-desktop only
> shows XFCE. How can I get bspwm added to this file?
> Or is there a way to get bspmwmrc file read automatically?

I believe 'exec bspwm' will read bspwmrc from the right location , that
file is for bspwm not for shell (to be sourced).

> At the login screen, although XFCE and BSPWM are both installed there is
> only a login prompt. To run XFCE I have to remove the ~/.xsession file.
> XFCE was installed during installation of GUIX, after install as regular
> user I install BSPWM.

Okay, bspwm does have a share/xsessions/bspwm.desktop file, so if you
put it in the 'packages' field of the 'operating-system', it should
be available in the gdm login manager.

To allow selected xfce to run, use 'exec "$@"' in ~/.xsession instead of
'exec bspwm'.

Hope this will be helpful!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]