[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with Shepherd after `guix home reconfigure`

From: Hilton Chain
Subject: Re: Problem with Shepherd after `guix home reconfigure`
Date: Tue, 22 Aug 2023 23:18:15 +0800

On Tue, 22 Aug 2023 21:51:07 +0800,
Tanguy LE CARROUR wrote:
> Hi Hilton,
> First of, I have to apologize to Shep[H]erd for the typo! Soooorry! 😅
> I've just fixed it in the subject.

No worry :)

> > Thank you for reporting the issue!
> >
> > This is caused by a missing module in mcron's service definition, and
> > now it should be fixed in 552d0703776c532f25498d5cb852c3c497cb9252.
> >
> > Please run `guix pull', then reconfigure the home environment.
> Much better! Thanks! 👍
> I still have an error message, though:

If you happen to use the system mcron service as well, please pull to
the latest commit again, my bad :(

> ```
> $ guix home reconfigure
> # […]
> Loading /gnu/store/zbfyaxxigns5lqyxhxzxhm92w54ns1cz-shepherd.conf.
> herd: error: exception caught while executing 'load' on service 'root':
> In procedure fport_write: Input/output error
> ```
> I've just tried something that, as weird as it sounds, I had never done 
> before:
> `herd stop mcron`! And… it just hangs forever!? I guess it not the
> expected behaviour?! 🤔
> I `ctrl+c`-ed it and, now, `herd status` also hangs forever!? 😞
> I'll see if everything goes back to normal after the next reboot…

I don't know much about Shepherd but rebooting seems to be the only
solution when it hangs...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]