[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: LaTeX: Need help with packaging a book in GNU Guix

From: Artyom V. Poptsov
Subject: Re: LaTeX: Need help with packaging a book in GNU Guix
Date: Tue, 29 Aug 2023 21:26:49 +0300
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.2 (gnu/linux)

Hello Nicolas!

> I then suggest to add `texlive-fontspec' (a few kB) instead of `texlive'
> (3 GB) to the inputs.

Thanks, that worked out indeed.  I've added other LaTeX packages as
well, searching by the required ".sty" files.

But then, I ran into the following error:

--8<---------------cut here---------------start------------->8---
Package rerunfilecheck Info: Checksums for `sparc.out':
(rerunfilecheck)             Before: <no file>
(rerunfilecheck)             After:  8A9E5CFD2193CCDADFE90D96E3F45333;20690.
runsystem(rm sparc.pyg)...executed.

Here is how much of TeX's memory you used:
 66386 strings out of 476682
 1790478 string characters out of 5779954
 2503753 words of memory out of 5000000
 84784 multiletter control sequences out of 15000+600000
 516911 words of font info for 97 fonts, out of 8000000 for 9000
 1348 hyphenation exceptions out of 8191
 94i,16n,92p,2254b,2061s stack positions out of 

Output written on sparc.xdv (133 pages, 2587352 bytes).
INDEX     sparc
 /usr/bin/env: bad interpreter: No such file or directory
make: *** [Makefile:77: make_glossary] Error 1
make: *** Waiting for unfinished jobs....
--8<---------------cut here---------------end--------------->8---

It looks like "makeglossaries" cannot find "/usr/bin/env" program.  I
checked where "env" can be found inside the builder context:

--8<---------------cut here---------------start------------->8---
  (list #:phases
        #~(modify-phases %standard-phases
            (add-after 'unpack 'debug
                       (lambda _
                         (invoke "which" "env")))
--8<---------------cut here---------------end--------------->8---

And the full path is:

But "makeglossaries" script seems to have a wrong path:

--8<---------------cut here---------------start------------->8---
$ head -1 
#!/usr/bin/env perl
--8<---------------cut here---------------end--------------->8---

Maybe there should be a symlink to "/bin/env" or something.  Strangely
enough when I add "texlive" to the inputs, the problem is gone.

Any ideas?


- avp

Artyom "avp" Poptsov <>
Home page:
CADR Hackerspace co-founder:
GPG: D0C2 EAC1 3310 822D 98DE  B57C E9C5 A2D9 0898 A02F

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]