[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

booting the hurd

From: Cameron
Subject: booting the hurd
Date: 12 Jan 2002 04:37:49 -0800


I've installed debian gnu/hurd(that name's a mouthful) via the H2 hurd

So far so good, I've even figured out how to use grub (the docs were
right, I DO like it better than lilo!).

Ok, with that being said, I still can't boot the hurd, I haven't even
done it once.

I've followed the instructions of a number of different docs, with the
same results.

This is what happens, I load the kernel, I load the necessary modules:
I attempt to boot the kernel, and then everything stops from there, I
suppose the system just freezes as I don't get any messages after I
attempt a boot (no, I didn't touch the keyboard).
In fact, I have to hard reboot.

How have I tried to use grub? I'll give an example:

find /boot/gnumach.gz

root (hd#,#)

kernel /boot/gnumach.gz

module /boot/serverboot.gz


I get no boot messages of ANY kind. I have tried other methods for the
module line, such as 
module /hurd/ext2fs.static
--host-priv-port=${host-port} --device-master-port=${device-port}
-T typed ${root} $(task-create) $(task-resume)

Of course I put it all on the same line.

Could this problem be from IRQ sharing? I know that's a problem, but I
couldn't find anything stating whether irq sharing would prevent ANY
booting (like what I get) or if the hurd would give me an error message
of some sort. I read something rather ambiguous that sorta implies that
the hurd might give me an error of some sort.

In fact, I'm rather unclear how to to boot the hurd period, different
docs say different things.

Could you guys maybe share with me your (various?) ways of booting the




reply via email to

[Prev in Thread] Current Thread [Next in Thread]