[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Utilities required to boot OSKIT-MACH

From: Matej Kosik
Subject: Re: Utilities required to boot OSKIT-MACH
Date: Tue, 09 Jul 2002 20:24:39 -0100

Ramesh wrote: 
> Hi
> Plz anybody help me to boot oskit-mach,
> 1) What are all the minimum utilities and libraries
> required in the root  partition (Like ramdisk in Linux
> kernel) ??

Hi Ramesh

Some time ago,
`Kevin Kreamer' posted on `Sat, 1 Sep 2001 15:54:43 -0500'
a mail with an attachment `oskit-mach.sgml' which seems to
be describing the `oskit-mach' instalation procedure.

(build it with `docbook2html oskit-mach.sgml')

I did not try to find its more up2date version, however
you will at least have some proposition (either true, or false.)

However, if you have a working hurd system (running on 
for examle `gnumach-1.3'), you can build and boot `oskit-mach'
also on this system (I tried it today and I it worked.)

If this not help you, you need not to read the rest of this mail.


instalation of `oskit-mach' (and also `gnumach') depends on
installation of `oskit'. If you installed the Hurd from four
CD-s (as me), you will probably have old version of `oskit'.


building and installing oskit:

        # on Linux
        wget ; printf
        # put this file somewhere, where you can use from the hurd
        # e.g. to ITS `/src' directory

        # on Hurd
        cd /src
        tar xvzf oskit-20020317.tar.gz
        cd oskit-20020317
        ./configure && make && make install; printf "\a"

oskit can be installed in the same way also under Linux (I tried it,
there were no problems)

more information about `oskit' can be found in its manual
(its resides in `')
((writing this mail off-line, so I can't check it, but it is
  probably somewhere there))
try at least booting `Hello kernel' for now and look at
its build-command (in the Makefile), it is fun.


building and installing oskit-mach:

        # on Linux
        cvs login &&
        cvs -d co -d
oskit-mach -r oskit-branch -P gnumach ; printf "\a"
        # put these sources somewhere where you can access them from hurd
        # I suggest you to put it also (as oskit) to the hurd's `/src'
        # directory

        # on Hurd
        cd oskit-mach &&
        autoheader &&
        OSKIT_LIBDIR=/local/lib/oskit ./configure &&
        make &&
        make install &&
        cd /boot &&
        # this is not required; you need not do it
        gzip -f oskit-mach
        printf "\a"

You can try it out. (during grub's booting offer edit the
hurd entry and change `gnumach.gz' to `oskit-mach.gz')


Although, there seem to remain some minor problems
        - the terminal does not understand ANSI characters (?)
                => do not try to use colorized `ls'
                => do not use `mach' instead of `mach-color' in
                   your `/etc/ttys'
                => use `ed' instead of `nano' (if you are thinking differently)
                => manual pages work only when `export TERM=vt52s'
                => the terminals which I tried out were not "smart enough"
                   to run `info'
                => ... (the things are different)
        - setting up swap fails (either during the boot proces
          or after `swapon /dev/hd0s5' attempt fails with the message

...............swapon: /dev/hd0s5: No such device or address

          even if gnumach happily swaps on `/dev/hd0s5' 

          (I tried also to swap on formatted Linux ext2 partition (also 500M),
           I got the same result,
           I did not try to swap to an ordinary file though)

        - I didn't also succeed in mounting a cdrom (on oskit-mach)


> Regards
> Ramesh
> =====
> __________________________________________________
> Do You Yahoo!?
> Sign up for SBC Yahoo! Dial - First Month Free
> _______________________________________________
> Help-hurd mailing list


reply via email to

[Prev in Thread] Current Thread [Next in Thread]