[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

New GNUMach Error

From: Luis Araujo
Subject: New GNUMach Error
Date: Mon, 2 Jun 2003 06:44:14 -0500 (CDT)

Hi everyone

In file included from /usr/include/string.h:48,
                 from ../oskit/x86/main.c:32:
/usr/include/strings.h:36: redefinition of `size_t'
/usr/local/include/oskit/c/unistd.h:25: `size_t'
previously declared here
make: *** [main.o] Error 1

This is what i get when i try to compile the gnumach
cvs version with the oskit cvs version.

I was thinking that could be some options i need to
set in the modules.x86.pc file. Ive disabled libc, and
posix/sys libraries, im not sure... but after that, it
gives also several errors.

It seems to me like GNUmach is looking for both libc
and oskit headers, and it get confused with
declaration of variables and stuuf like that.
In this case what could do?.. i tried changing a few
things in /usr/include/strings.h and
/usr/local/include/oskit/c/unistd.h (apparaently these
are the two headers generating the errors) but still
gives the same error.

This is what i pass to configure=

CFLAGS=-I/usr/local/include MIG=/usr/local/bin/mig
OSKIT_LIBDIR=/usr/local/lib/oskit ../configure

Luis Araujo

Do You Yahoo!?
Información de Estados Unidos y América Latina, en Yahoo! Noticias.
Visítanos en

reply via email to

[Prev in Thread] Current Thread [Next in Thread]