[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs21 in Hurd.

From: Ole Andre Birkedal
Subject: Re: Emacs21 in Hurd.
Date: Sun, 22 Jun 2003 16:07:06 +0200
User-agent: Gnus/5.1002 (Gnus v5.10.2) Emacs/21.3 (gnu/linux) (Gaël Le Mignot) writes:

> Hello Ole!
> Sun, 22 Jun 2003 03:18:14 +0200, you wrote: 
>  > Hello there.
> Hello !
>  > I am trying to run Emacs21 in hurd.
>  > When i run `emacs` it gives me an error
>  > saying it can't find libXaw3d, but I do
>  > have libXaw3d installed, and the library
>  > file which it is asking for (
>  > is located in my libdirectory which is also
>  > a path to in /etc/, and I did run
>  > `ldconfig`, so I really have no idea what
>  > could be wrong here.
> is not used on GNU/Hurd.
> You should use the environement variable LD_LIBRARY_PATH.
I tried that just now, i set LD_LIBRARY_PATH to /X11R6/lib where
the file were located, but still no luck.
I also tried running ldconfig after that, but didn't do much.
> In the future, all the  librabries should (virtually) be in /lib using
> a UnionFS (or ShadowFS) translator.
> Also take note that there is a bug in xlib, and Emacs doesn't run in X
> mode (use emacs -nw if you run it from X)
I am not running Emacs in Xfree, and even if i supply the -nw
argument it complains about the library which it can not find.
> -- 
> Gael Le Mignot "Kilobug" - -
> GSM         : (in France)   ICQ UIN   : 7299959
> Fingerprint : 1F2C 9804 7505 79DF 95E6 7323 B66B F67B 7103 C5DA
> Member of HurdFr: - The GNU Hurd:

Note to self: get smarter troll to guard door

reply via email to

[Prev in Thread] Current Thread [Next in Thread]