[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: remote debugging stubs (EXC_BAD_ACCESS)

From: Marco Gerards
Subject: Re: remote debugging stubs (EXC_BAD_ACCESS)
Date: 10 Sep 2003 22:34:44 +0200
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2

Greg Buchholz <> writes:

> > Greg Buchholz <> writes:
> > >   Okay, when I attach to the boot process, I can set breakpoints
> > > fine, but when I continue, I get the following message (in gdb)...
> > > Can't wain for pid 174: No child processes.
> > >
> > > ...then when I hit enter to continue the paused "boot", gdb complains...
> > >
> > > Pid 174 died with unknown exit status using SIGKILL
> > > Program termintaed with signal SIGKILL, Killed.
> > > The program no longer exists.
>       This problem was solved by putting a sleep(30) at the beginning of
> the program to give me enough time to attach to the running process (gdb
> seemed to have problems because the programing wasn't running yet).  Then
> I start debugging , but out of the blue I get an error like...
> Program received signal EXC_BAD_ACCESS, Could not access memory.
> 0x0806c203 in _hurd_ports_use()

Have a look at all thread and where they are.  Perhaps it isn't in
_hurd_ports_use, but in another thread.  "info thr" for all threads
and "thr 1" for thread one, etc.  Just have a look at all backtraces.
> ...Trying multiple different times I always get the same error
> (_hurd_ports_use), but at different locations in the code.  My gut feeling
> is that this is somehow being caused by gdb itself.  I'll also note that I
> get the following error message when gdb starts up...

Yes, it just shows the function of the first thread.  My guess the
problem is in another thread.

>       Warning: can't modify tracing state for pid202: No signal thread.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]