[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: contrib/marcus/gnu.tar.gz last year and this year

From: Marco Gerards
Subject: Re: contrib/marcus/gnu.tar.gz last year and this year
Date: 29 Oct 2003 23:03:10 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2

sigbj-st <> writes:

> :
> What I mean to say here is that last year I tried to install the 20.8.02 tar 
> ball from . I assume that there has not been any change 
> in 
> the MBrinkm tar.gz since august 2002.Otherwise I would assume that the date  
> would have changed so that I would have noticed that.
> Last year I reported that the hurd boot froze at a certain stage and kernel 
> panic. I tried contrib/marcus on the same machine for fun to-day (but I use 
> the K4-Debian now).The same-procedure-as-last-year happened,but when I edited 
> the first modul-line /hurd/ext2fs.static to erase the "--readonly" switch, 
> the 
> Hurd continued past the hang to single-user runlevel as it should. From here 
> I 
> could continue the regular ./native-install.
> Upon a second boot Hurd this time actually accepted  "--readonly" on that 
> modular line in grub,and I ran the ./native-install a second time as 
> requested.
> Now, on third boot as multiuser the message was that "could not fsck, could 
> not mount readonly", or something like that,so I had to add --readonly on the 
> ext2fs.static module command line. Does this sound weard to you?

This is a bug that was fixed around that time.  Upgrading will fix
this problem.

> Has the grub boot-setup for Hurd changed as to the -s option in the kernel 
> commandline and --readonly option in the ext2fs.static commandline?

No.  "-s" is only required for single used mode (I have never used
single user mode, it seems not really required :)).  --readonly is a
workaround for this bug.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]