[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

eepro100 detection fail? (and a success story :-))

From: arief#
Subject: eepro100 detection fail? (and a success story :-))
Date: Mon, 26 Jul 2004 16:07:06 +0700

Dear all,

I just got myself 'inspired' to install GNU/Hurd on my Thinkpad T30.

I have some spare spaces in HD, but no partition yet, having so much
faith in GNU Softwares, I fight Bootdisk-HOWTO and went create my own
boot/root disk (do this all at home, and I dont have access to net at
home, that's why I couldn't download nice shiny boot/root disk from the

The next day at office (with nice internet connections),
With the boot/root disk, I use GNU parted to resize my partitions. 
Faithfully, ofcourse, it worked. Then I apt-get install crosshurd, and
went over installing deb-packages needed to install GNU.

Writing whatever needed for GRUB, reboot, booting GNU for the first
time, running native-install (strangely I didn't have to type twice),
reboot. Another native-install, and reboot. 

Voila, I got myself a nice delicious GNU/Hurd running. There was a
little problem saying that something cannot run, so I didn't get login
prompt, but directly into the shell. Just do chmod 755 to the thing (I
forgot it something ends with 'rc').

Back at home again, I read all the docs I could find about the beast.
Learn quite alot of stuf (ohh so that's what translator all about),
exciting, can't wait to try X on my GNU shiny system... ;-)

When I get to office, I quickly reboot to GNU again, and preparing to do
apt-get update. That's when this hits me.

I dont have a working eth0 device.
In linux I use eepro100 as the driver, and I can see that this is
supported in gnumach. But nothing appears as eepro100 in /dev/klog.
Funny, I guess, so I take a few more ups and downs in the hurd.

Finally I get myself compiling gnumach that I got from debian's ftp
(package name: gnumach_20040229.orig.tar.gz) with this configure
command: ./configure --enable-lpr --enable-floppy --enable-ide
--enable-eexpresspro100 --host=i386-gnu --build=i386-linux.

Install it, and take another reboot. 
And I still can't see eth0.

I've tried gnumach-1.3, but it wont compile, and I dont know assembly
enough to fix it. 

What happened? I dont know. 

Oh one more thing, I don't have CVS access from my office, so I can't
try oskit-mach. Anyone willing to help me on this? If someone can just
give me the sources (I can accept it by email on my gmail account
(, and yes I got one)), or let me know another
address so I can just download the tarball, I'd really appreciate it.

Below here, I attach my lspci -v output.

Best Regards

Attachment: lspciv
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]