[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: hurd installation

From: Danilo Segan
Subject: Re: hurd installation
Date: Tue, 01 Feb 2005 14:02:34 +0100
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/21.3.50 (gnu/linux)

Yesterday at 18:32, ANIL C. JOHN wrote:

> I did "rescue root=/dev/hdb3" when booted from CD to boot from that
> partition, it also stalled after booting for a  
> while, and found the following messages before stall:(by the way
> hurd is installed in partition /dev/hdb3 and mount on /gnu) 

This is funny :)  You've actually tried to run Linux kernel using GNU
filesystem.  I never tried it, but I know that GNU/Hurd can't be
booted off CD yet. 

> "Partition Check
> hdb: hdb1 hdb2 <hdb5 hdb6 hdb7 hdb8 hdb9> hdb3
> apm: BIOS not found
> VFS: mount root (ext2 filesystem) readonly
> Freeing unused kernel memory: 72k freed
> Warning: unable to open an initial console"
> -------------------------------------------------
> ........................execution stopped.....................................
> why is it showing that BIOS not found?, is it because it is
> /dev/hdb1 (on C: fat32)? 

It only says that Linux kernel can't find APM BIOS, no need to be
alarmed by this :)

> Is it the reason why hurd is NOT booting?

Nope, this has nothing to do with GNU Hurd whatsoever.  If nothing
else, now you know another way to make Linux fail to boot. :)

> And why is it showing "unable to open an initial console", and after
> that why does execution stop?

Because Linux kernel is unable to find /dev/console (or whatever) on
your GNU partition.  It's all due to mess-up above.

I'm sorry that I can't _really_ help!  Check if the filesystem type
was really ext2-Hurd (follow Marco's advise), because I hope Linux
would complain if ostype is not set to linux on ext2 filesystems 
it tries to use as root filesystems.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]