[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Booting the hurd for the fist time fails

From: Joern . Sesterhenn
Subject: Booting the hurd for the fist time fails
Date: Tue, 08 Feb 2005 13:16:57 +0100
User-agent: nail 10.6 11/15/03


I tried to install the hurd on a Debian GNU/Linux box
on a logical partion /dev/hd5. Grub recognises it at (hd0,4)
and finds /boot.gnumach.gz.
The hurd is under /gnu. It was installed using debian-crosshurd.

I am able to boot Linux from Grub. /boot is on (hd0,0)

I followed all instructions in Debian GNU/Hurd Installation.
It fails after the boot commands and reboots the computer into the original 
boot menu. Nothing  from hurd is displayd at all on the screen.

Here are the commands I use interactively

grub> kernel (hd0,4)/boot/gnumach.gz root=device:hd0s5 -s
grub> module (hd0,4)/hurd/ext2fs.static \
   --multiboot-command-line=${kernel-command-line} \
   --host-priv-port=${host-port} \
   --device-master-port=${device-port} \
   --exec-server-task=${exec-task} -T typed ${root} \
   $(task-create) $(task-resume)
  grub> module (hd0,4/lib/ /hurd/exec $(exec-task=task-create)
  grub> boot

My questions:

0) Line extension seems not to work with my grub (  0.95+cvs200406 ). 
I get command not found after the second line.
Instead I continue typing which seem fine. Is this correct?

1) is it possible to use menu.lst instead of typing everything over and over 
again when booting the first time? If so, what is the commad set, in particular 
how is the single user mode (-s) specified?

2) Is the device:hd0s5 correct? in
grub> kernel (hd0,4)/boot/gnumach.gz root=device:hd0s5 -s
3) I issue the command
grub>  module (hd0,4)/lib/ /hurd/exec ......
is the path to exec specified correctly? When on another partition? I also 
tried ..... (hd0,4)/hurd/exec ..... with no sucess.

5) Aside from my questions do I have someting fundamentally wrong?

Thank you,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]