[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: pfinet: malformed address

From: Ulrich Grün
Subject: Re: pfinet: malformed address
Date: Sun, 26 Nov 2006 13:38:09 +0100
User-agent: KMail/1.8

Also schrieb Richard Braun am Sonntag, 26. November 2006 10:31:
> On Sun, Nov 26, 2006 at 09:33:50AM +0100, Ulrich Grün wrote:
> > I'm using the Hurd in a virtual machine (vmware. Network=bridged). When I
> > try to configure the network, I end up in some error message that I don't
> > understand.
> >
> > The command I type:
> > ' # settrans -fgap /servers/socket/2 /hurd/pfinet -i eth1 -a
> > -m '
> >
> > The error message:
> > ' pfinet: malformed address '
> This is strange, the given addresses are fine. Make sure eth1 is the
> right interface (use devprobe or the kernel logger - /dev/klog).

I think I know what went wrong. When I gave the command, I was logged in as 
user root. I rebooted in -s and gave the command before logging in. Now, I 
didn't get any error message. 
Do I need to give this command every time I boot in Hurd?

After I rebooted, I tried to use 'apt-get' and ftp to '', but I get 
only connection errors. Somehow, setting up ethernet didn't work (I edited 
the /etc/resolv.conf with the DNS addresses.)

What about ' /dev/klog '?

A strange thing too (has nothing to do with the ethernet problem, probably):
logging of messages doesn't work. In ' /var/log/messages ', I only see 
'restart' and '---MARK---' messages, nothing more. How can I turn the logging 

> > I got the IP address and netmask from my Debian installation, also from
> > within vmware. I first tried the command with -g (and some address) with
> > no difference.
> What do you mean by this ? Is this address already used ?

When I boot Debian in a virtual machine, I find these IP address and netmask. 
When I shut debian down and boot the Hurd, I think that I should use the same 
addresses. I don't use a proxy, so I think that I don't need the -g (I don't 
know of any gateway address).

> I still wonder, though, why people use the proprietary vmware when there
> are free alternatives like qemu, and a ready-to-use image for it...

I'll try qemu.
Are there ready Hurd images? I'll check them out as well.

Ulrich Grün.
      My Box said: "Install WinXP/Vista/Longhorn (what ever) or better ..." 
                                   So I installed Linux.  
Ulrich Grün
  Grenadadreef 1-A
    3563 HE  UTRECHT
System: P4-2,4GHz, 1GB. OS: SuSE 9.3, Kernel:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]