[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Root device not found at boot

From: Balint Menyhart
Subject: Root device not found at boot
Date: Tue, 27 Nov 2007 13:18:41 +0000


I have followed the different steps to install GNU/Hurd as described on
the Debian web site. When coming to boot the first time onto my new
system, The boot process stops and I get the following error message:

start (hd0,3)/hurd/ext2fs.static: (hd0,3)/hurd/ext2fs.static:
device:hd0s4: No such device or address

Last successful command's output before this is:

task loaded: (hd0,3)/lib/ /hurd/exec

So I guess my root=device:hd0s4 is wrong.
I have tried hd[0-4]s4 and hd0s[3-5] as well, with the same error as

I am on a Dell Inspiron 1501 laptop, I have only 1 SATA hard disk
partitioned and used the following way:

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/sda2       /               ext3    defaults,errors=remount-ro 0
/dev/sda3       /home           ext3    defaults        0       2
/dev/sda5       none            swap    sw              0       0
/dev/hda        /media/cdrom0   udf,iso9660 user,noauto     0       0

and my currently not mounted /dev/sda4 (ext2) containing my GNU/Hurd

Any suggestion?
Thanks in advance,

Balint Menyhart

reply via email to

[Prev in Thread] Current Thread [Next in Thread]