[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Fwd: Some qemu+hurd questions]

From: Svante Signell
Subject: Re: [Fwd: Some qemu+hurd questions]
Date: Mon, 01 Nov 2010 22:39:50 +0100

On Mon, 2010-11-01 at 17:34 +0100, Samuel Thibault wrote:
> Svante Signell, le Sun 31 Oct 2010 19:40:29 +0100, a écrit :
> > Installing Hurd with mini.iso as show in README.txt:
> > qemu -m 512 -net nic,model=ne2k_pci -net user -hda hurd-install.qemu
> > -cdrom ~/SW/hurd-installer/mini.iso -boot d
> > 
> > Installation went well, apt and grub2 work perfectly, however extremely
> > slow, several hours for the installation.
> This is not really surprising for a qemu-emulated installation.


> > After the install I tried with
> > -m 256, same common problem: one of the two CPUs loaded 100%, the other
> > idle, almost all memory used and sloow.
> Like Linux, Mach tries to use as much memory as possible to avoid Disk
> I/O.

OK, seems like I need more memory.

> > Running the installed Hurd:
> > qemu -m 256 -net nic,model=ne2k_pci -net user -hda hurd-install.qemu
> > 
> > - Does qemu have a terminal where I can get a scrollbar, without it is
> > very difficult to catch all output.
> Yes, you can use the -curses option to use text mode.

In gnome-terminal -curses did not work! I did not get any echo of the
commands written :(
However, starting qemu from xterm -sb -rightbar seems to work.
No graphical keys, like C-A-n etc commands worked!

> > - How to shut down Hurd in qemu properly? Just closing the qemu window
> > hurd complained on an unclean shutdown and had to check disks.
> Yes, it's just like you had cut the power cable. You could send a wish
> request to the qemu devel mailing list for a "power" button" which
> triggers ACPI stuff. It's however not supported by GNU Mach :)
> > The solution I found so far is to shut down Hurd as root in the qemu
> > window before closing the window.
> That's the expected way.

Will shut down Hurd with halt before exiting qemu from now on.

> > - When installing Hurd, no Swedish locale was found, I used the default.
> Like standard Debian systems, you can install the locales package to get
> Swedish locale support.
> > The problem is that the US keyboard is used by qemu+hurd, while I have a
> > Swedish keyboard. It is very difficult to type correctly since common
> > characters are at strange positions, e.g. - is /, <shift>* is |, ö is :,
> > etc. How do I get a Swedish keyboard mapping working in qemu+hurd? 
> You need to run the Hurd console and use its xkb driver. It has however
> not been really maintained and might just not even work ATM.

I tried to get it working, but console-driver-xkb seems to be broken,
and console-tools and keyboard-configuration seem to be Linux only.
An arch-hurd developer had patches to console-driver-xkb sent to
bug-hurd in August,
Have they bee applied upstream? Looks like no updated debian package

> > - qemu seems to grab the mouse when clicking on the window, making it
> > impossible to copy text from that window somewhere else. Is that
> > solvable?
> Again, use -curses.

Thanks, this works, at least in xterm!

> > - qemu-kvm is also available in addition to qemu. Would things be faster
> > with it, there seems to be some kernel modules added? Does my CPU, see
> > below, support virtualisation?
> As said by somebody else, it doesn't. You should however try to compile
> the kqemu module, which accelerates emulation without special hardware
> support.

Where to find kqemu? Did not find it in Debian.

> > - Availability of Emacs, Arch Hurd has a working version, not Debian.
> > I'm not so fluent in using vi or nano.
> Did you try to install the emacs package? Debian doesn't install it by
> default in the base system just because it takes quite some room
> compared to e.g. nano, but it should be installable ATM.

apt-get install emacs23-nox                                   
Reading package lists...
Building dependency tree

Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
emacs23-nox : Depends: emacs23-bin-common (= 23.1+1-3) but it is not
going to be installed
E: Broken packages

> > Computer is a dual Intel(R) Pentium(R) 4 CPU 3.00GHz 32bit box running
> > Debian unstable. I have only 512M memory on the box. Is that too little
> > to run Linux+Hurd simultaneously?
> It's a bit short on memory if you want to use Linux as a desktop with
> e.g. run etc.

OK, need to get more memory then. Got some speedup with:
-smp cores=2

- Spurious output: kd_setleds1: unexpected state (1)
- Complaints at boot on /etc/motd being a dangling symlink, however:
ls -l /etc/motd
lrwxr-xr-x 1 root root 13 Oct 28 00:11 /etc/motd -> /var/run/motd


reply via email to

[Prev in Thread] Current Thread [Next in Thread]