[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bootloader Problems

From: htm
Subject: Bootloader Problems
Date: Fri, 31 Dec 2010 21:28:46 -0500 (EST)
User-agent: SquirrelMail/1.4.13

I tried to install Debian Gnu/Hurd with their Installer CD und it worked
well until the bootloader part. I choose not to install in MBR, I wanted
the loader on a partition. I entered hd1,0 got an error and discovered
that GRUB2 wants hd1,1 This seemed to produce no error. Finishing
Installtion and rebooting the partition was unbootable from my MBR
bootloader (PLOP Boot Manager) and chainloading it from Grub 0.98 (from
Gentoo) brought me an error 13 (~ unrecognized, not executable format).
I looked for Legacy Grub Commands to load Hurd and then rewrite Grub2 to
the desired partition but they did not work too:
title Debian Hurd Direct
root (hd1,0)
kernel /boot/gnumach.gz root=device:hd1s1 -s
module  /hurd/ext2fs.static ext2fs \
        --multiboot-command-line='${kernel-command-line}' \
        --host-priv-port='${host-port}' \
        --device-master-port='${device-port}' \
        --exec-server-task='${exec-task}' -T typed '${root}' \
        '$(task-create)' '$(task-resume)'
module  /lib/ exec /hurd/exec '$(exec-task=task-create)'

The kernel is apparently loading and providing messages, but I get no
shell or other interaction ability.
So two questions:
What are the right commands to boot Debian Hurd from Legacy Grub?
Or is there a way to chroot to it and install Grub2 again?
(Or do I have to run installation again?)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]