[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Debian Gnu/Hurd - Configure Network

From: zac storer
Subject: Debian Gnu/Hurd - Configure Network
Date: Thu, 31 May 2012 16:46:55 -0600


I am a newbie. I have installed debian gnu/hurd alongside debian gnu/linux on real hw. I am trying to configure the network with dhclient.
I am following the following tutorials: and .
I am also following the debian hurd mailing list, namely: .
I have updated the hurd, gnumach, netdde, and isc-dhcp-client packages. Everything seems to be fine.
I then issue a dhclient -v /dev/eth0, and get the following error:

../../../../lib/isc/unix/socket.c:5636: setsockopt(21, IPV6_V6ONLY) failed: (?)(?)
... Copyright info here ...

fsysopts: /servers/socket/2: -i /dev/eth0: (ipc/mig) server died
Error getting hardware address for "/dev/eth0": No such device

I then tried:

# settrans -fg /dev/eth0
# rm /dev/eth0
# settrans -c /dev/eth0 /hurd/devnode -M /dev/netdde eth0

when I run dhclient -v /dev/eth0 I still get the same error.

I don't know what to do next. I'm looking through the hurd documentation to see if I can find out more.
It would be really neat to have the hurd running on real hw with the network enabled.

Here is my lspci: 01:09.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)



reply via email to

[Prev in Thread] Current Thread [Next in Thread]