[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Testsuite of libidn 1.20 fails in gnulib

From: Dagobert Michelsen
Subject: Re: Testsuite of libidn 1.20 fails in gnulib
Date: Wed, 4 May 2011 18:03:31 +0200

Hi Simon,

Am 04.05.2011 um 17:58 schrieb Simon Josefsson:
> Dagobert Michelsen <address@hidden> writes:
>> I am trying to compile libidn 1.20 on Solaris 9 Sparc with Sun Studio 12
>> and I get a failing test in the gnulib-part (cc'ed bug-gnulib@ for this):
>>> DEPDIR=.deps depmode=none /bin/bash ../../build-aux/depcomp \
>>> /opt/SUNWspro/bin/cc -DHAVE_CONFIG_H -I. -I../..
>>> -DIN_LIBIDN_GNULIB_TESTS=1 -I. -I. -I../.. -I./../.. -I../../lib/gl
>>> -I./../../lib/gl -I/opt/csw/include -D_REENTRANT -D_REENTRANT -xO3
>>> -m32 -xarch=v8 -xnorunpath -c -o test-stdint.o test-stdint.c
>>> "test-stdint.c", line 63: warning: implicit function declaration: INT64_C
>>> "test-stdint.c", line 63: non-constant initializer: op "CALL"
>>> "test-stdint.c", line 83: warning: implicit function declaration: UINT64_C
>>> "test-stdint.c", line 83: non-constant initializer: op "CALL"
>>> "test-stdint.c", line 240: non-constant initializer: op "CALL"
>>> "test-stdint.c", line 246: non-constant initializer: op "CALL"
>>> "test-stdint.c", line 351: non-constant bit-field size
>>> "test-stdint.c", line 353: non-constant bit-field size
>>> cc: acomp failed for test-stdint.c
>>> gmake[4]: *** [test-stdint.o] Error 2
> Hi Dagobert.  I have tried building libidn 1.21 on OpenCSW's testing10s
> machine and it worked fine.  Let me know if it doesn't work for you.

Yes, it works fine, I have already updated my package.

Best regard

  -- Dago

reply via email to

[Prev in Thread] Current Thread [Next in Thread]