[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: CVS 1.11 fails to create administrative files when using a re mote r

From: Trott, David
Subject: RE: CVS 1.11 fails to create administrative files when using a re mote repository
Date: Thu, 28 Sep 2000 12:22:47 -0700

I see these as two distinct problems.

Problem 1 - Checking out into empty directories.

Sorry I initially tried to simply this problem.

What I am actually trying to do is use CVS for part (but not all) of an existing directory structure, so some directories exist and some do not, CVS handles this fine if the repository is local but not if it is remote. Hence I see this as a bug in CVS, not a problem with what I am trying to do.

Additional I have duplicated this with 2 Linux boxes and with version 1.10.8 so it is not specific to NT/2000 and it is not a new bug.

Problem 2 - Checking out module "."

This problem does *NOT* occur with a Linux client so I assume it to be Win2000 and possibly Win NT specific bug.

Note: Your fix of adding a name "foo" for module . (in the modules file) works, but I would still like to be able to use . as I could in CVS 1.10.5


-----Original Message-----
From: Garth Winter Webb [mailto:address@hidden]
Sent: Thursday, September 28, 2000 11:05 AM
To: Trott, David
Cc: 'address@hidden'
Subject: Re: CVS 1.11 fails to create administrative files when using a
remote repository

Why are you creating the 'alpha' directory?  A checkout should create this
directory for you.  I'm not sure why this would cause a problem for CVS,
but not knowing much about how well CVS runs under windows and that CVS
seems to be trying to find CVS/Entries indicates that its confused by the
empty directory.
        Also these examples assume a root module that you haven't
named.  For the sake of this example lets just say that the module name is
'foo'.  I would suggest this:

* Do a CVS checkout on the module you want to work on first.

$ cvs checkout foo

* To update remote hosts of file changes or added directories use 'update'
with the '-d' option

$ cd foo
$ cvs update -d

Try to be explicit as possible;  use the real module name rather
than '.'.  Use 'checkout' to create a new work area.  Use 'update' to
freshen files in an existing work area.  Use the '-d' option of update to
get any newly created directories in your work area.


On Thu, 28 Sep 2000, Trott, David wrote:

> Steps to reproduce:
> On Linux (Server)
> cvs co .
> mkdir alpha
> cvs add alpha
> echo hello > alpha/world
> cvs add alpha/world
> cvs commit alpha
> rm -r alpha
> mkdir alpha
> cvs co alpha
> *** Works Fine ***
> On Win2000 (Client)
> mkdir alpha
> cvs co alpha
> *** Errors ***
> Additionally when I run the command:
> cvs co .
> On the Win2000 box with CVS version  I get the following error
> cvs checkout: cannot open CVS/Entries for reading: No such file or directory
> cvs [checkout aborted]: no repository
> This works fine with version 1.10.5

reply via email to

[Prev in Thread] Current Thread [Next in Thread]