[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Urgh - more permission denies

From: Ashley M. Kirchner
Subject: Urgh - more permission denies
Date: Wed, 01 Nov 2000 16:03:36 -0700

    Ok, did some more things:

    a) recompiled with normal user (as opposed to being root)
    b) reinstalled
    c) adjusted my xinetd entry:

    # default: on
    # description: CVS Server
    service cvspserver
        flags           = REUSE
        disable         = no
        protocol        = tcp
        socket_type     = stream
        wait            = no
        user            = root
        env             = '$HOME=/CVS'
        server          = /usr/bin/cvs
        server_args     = -f --allow-root=/CVS pserver
        log_on_success  += DURATION USERID
        log_on_failure  += USERID

    d) reloaded xinetd

    And I still get:

    cvs server: cannot open /root/.cvsignore: Permission denied
    cvs [server aborted]: can't chdir(/root): Permission denied

    Now I'm lost.

    For the record, I also tried changing the 'user' variable to the
'cvs' user, and that gave me a setuid error.  (the user 'cvs' exists,
and it also owns '/CVS' and everything underneath that.)

    Let's see what other suggestions I can find in the archives.  -f
doesn't seem to like me very much.


W |
  |  I haven't lost my mind; it's backed up on tape somewhere.
  Ashley M. Kirchner <mailto:address@hidden>   .   303.442.6410 x130
  SysAdmin / Websmith                           .     800.441.3873 x130
  Photo Craft Laboratories, Inc.             .        eFax 248.671.0909                  .         3550 Arapahoe Ave #6
  .................. .  .  .     .               Boulder, CO 80303, USA

reply via email to

[Prev in Thread] Current Thread [Next in Thread]