[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Client/server CVS

From: vincerice
Subject: Client/server CVS
Date: Wed, 15 Nov 2000 00:18:28 -0000
User-agent: eGroups-EW/0.82

I am trying to get a client/server installation of CVS working 
between two Unix boxes.

I have downloaded the latest 1.11 sources and compiled them on the 
AIX box, and installed it in /usr/local/bin with the appropriate 
rights (all execute).  I have copied that version to the other AIX 

The inetd.conf on the server side has been modified to run cvs with 
the following line (it's all on one line in inetd.conf)
   cvs stream tcp nowait root /usr/local/bin/cvs cvs -f 
        --allow-root=/home/vrice/cvs pserver

Following the troubleshooting instructions, I have telneted to the 
port, and it gives the expected error
   cvs [pserver aborted]: bad auth protocol start:
so I believe that the inetd.conf is correct, and that it is properly 
listening and responding on the port.

I have done a cvs init in the above $CVSROOT, and it has the CVSROOT 
directory underneath it, with the appropriate files.  I have created 
a cvsuser user and a cvsusers group, and given ownership of the 
entire $CVSROOT tree to that user.  I have created a passwd file in 
$CVSROOT/cvsroot that has three entries:

I generated the passwords (the blahblahblah above) using three 
different methods (none of them have worked): I downloaded cvsadmin 
and used it, I used the perl trick listed on one of the download 
sites, and I used the crypt.exe included in cygwin.  I believe all 
three methods generate the appropriate passwords.  By "all three 
methods", I mean that I have interated replacing the passwords in 
both vrice and vrice2 above with generated passwords from the 
appropriate method, then tried to login, then re-generated them using 
the next method, tried to login, etc.

On the client AIX side, I try to login to cvs using
   cvs -d :pserver:<user>@m3:/u/vrice/cvs login

I get the following error (all on one line)
   cvs login: authorization failed: server m3 rejected access
       to /u/vrice/cvs for user vrice2

I get this error with any of the three users, even guest, which has 
no password on the cvs side.  I have confirmed the passwd file (as 
stated above), I have confirmed read rights on it and everything else 
in the $CVSROOT tree, I can rlogin from the client machine to the 
other.  In short, I don't know where else to look, or how else to 
debug this.  I have read the CVS manual, I have looked at a couple of 
the installation instruction sites, and as near as I can tell, I have 
done everything correctly.

Can someone either identify what is missing above, or give me some 
ideas on what else to check?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]