[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Admin -l : anyone worked with this?

From: Trott, David
Subject: Re: Admin -l : anyone worked with this?
Date: Wed, 7 Mar 2001 14:45:44 -0800

Apologies if I am on the wrong track here (I only caught the end of the thread) but assuming you are trying to deny access to all revisions of a given file not just a particular branch:

You may want to try changing the directory write permissions instead of the file permissions.

CVS in effect deletes the file and recreates it on commit hence removing write permission to the file has no effect (at least on UNIX systems).

If directory level granularity is not sufficient for your needs you can probably use the commitinfo file to deny commit access to specific files and/or users.

Alternatively you may be able to do something by setting the t bit on the directory, however I would not recommend this approach.


"Jesus Manuel NAVARRO LOPEZ" <address@hidden> wrote in message news:<address@hidden>...

> WT Medewerker wrote:
> >
> > >The easiest way (especially if it's only a one-time action).  Just take
> > >out write perms for that files.
> > >--
> > >SALUD,
> > >Jesús
> >
> > I did that but CVS changes the owner and overwrites the file while the
> > original file was marked
> > r--r--r--. I offcource was curious what happens when I chmod to 000 and
> > yes(!) it does not
> > not update any commits on the file. However I can not fetch the file when I
> > try to check it out
> > on a new location.
> > hmmmm interesting, somehow this must work. I'll trie changing the group
> > trough which this file may
> > be accessed.
> >
> I would bet your problem here is that you are running your CVS pserver
> as root (might be from inetd/xinetd?).  I would try running it as some
> other (non-superuser) user (look at your /etc/inetd.conf for this).
> --
> Jesús
> ***
> address@hidden
> ***

reply via email to

[Prev in Thread] Current Thread [Next in Thread]