[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: different access control to different users patch problem.

From: Derek R. Price
Subject: Re: different access control to different users patch problem.
Date: Fri, 23 Mar 2001 10:16:36 -0500

I've never used this patch before, so take the following advice with a
grain of salt:

address@hidden wrote:

> 1)I have down loaded the cvs1.11 in to Unix.

Is this the version the patch was originally created from?  If not you
can expect to do a bit of porting.

> 3) Now we tried to apply the patch( using 'patch -i patchname )
> to 'src' durectory inder cvs-1.11 and it gives some error saying that
> linking files are missing ( which are there in doc directory.
> 4) so we went to 'doc' directory and tried to apply the patch again
> using the same command. it gives error by saying 'missing some files'
> which we found in src directory.
> 5) So we merged both the directories 'doc' and 'src'.
>     And now tried to compile using make.

Merging directories shouldn't be necessary.  Most likely you are running
patch from the wrong location or stripping the wrong number of path
elements.  Read the patch file itself (the man page for patch shouldn't
hurt either) and look at the file names it is looking for.  If there are
path elements you can't duplicate (e.g. ccvs-orig & ccvs-final), they
should be 'stripped' using the -pN option to patch.  Use the remainder
of the paths to figure out where you should be running patch from.  i.e.
make sure that after any elements are stripped, the relative paths
remaining point to files.  You should have something left like
src/foo.c, src/bar.c,  & doc/cvs.texinfo and this would mean patch
should be run from the parent directory of src & doc.

> 6) Almost all files are successfully compiled butat the end it faild
> with the following error?
> Undefined                       first referenced
>  symbol                             in file
> change_perms                        add.o
> verify_read                         checkout.o
> passwd                              main.o
> change_owner                        add.o
> local_security                      add.o
> deluser                             main.o
> verify_admin                        admin.o
> chacl                               main.o
> verify_write                        commit.o
> adduser                             main.o
> lsacl                               main.o
> verify_create                       add.o
> ld: fatal: Symbol referencing errors. No output written to cvs
> collect2: ld returned 1 exit status

Versions of CVS prior to the current dev version created patches that
always put newly added files in '.' rather than where they should be.
It's possible that this happend and there is a new file containing these
functions in '.' (rather than 'src' or the like) that never got
compiled, but if your patch made the correct changes to src/Makefile
then I don't know why you didn't run into a missing file error earlier.

Of course, the new file may have been compiled and just not added to the
linking line.  Try grepping all *.c files for the missing functions or
search the patch file for the segment(s) which should have added these

Hope this helped.


Derek Price                      CVS Solutions Architect ( )
mailto:address@hidden         CollabNet ( )
I will not conduct my own fire drills.
I will not conduct my own fire drills.
I will not conduct my own fire drills...

          - Bart Simpson on chalkboard, _The Simpsons_

reply via email to

[Prev in Thread] Current Thread [Next in Thread]