[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 'newbie' here, having a problem with check-out

From: Eric Siegerman
Subject: Re: 'newbie' here, having a problem with check-out
Date: Fri, 23 Mar 2001 15:47:12 -0500
User-agent: Mutt/1.2.5i

On Fri, Mar 23, 2001 at 10:12:49AM -0500, Patrick Lynch wrote:
> [earlier steps consist basically of importing, then checking
> out into c:/docs with WinCVS]
> 4.4 committed the c:/docs directory...
> 4.5 at this point, everything is working fine...
> 4.6 tried to check out docs from the repository and got the msg: "...*PANIC*
> adminstration files missing...",

You shouldn't need to check out again at this point, merely
update.  After all, you already have a working directory.  Now,
if this script isn't quite correct, and what you actually did
    4.61 delete c:/docs
    4.62 try to do a "cvs update"
that would give you the result you saw, I think.

This certainly would:
    # import
    cd c:/docs          # compressing 2 dos commands into 1 :-)
    cvs import ...

    # make a CVS sandbox, but keep the old c:/docs as a backup
    cd c:/
    cvs co -d docs-cvs ...
    cd c:/docs-cvs

    # forgetting that you should be working in docs-cvs now :-(
    cd c:/docs
    # kaboom!  admin files are missing of course.

> 4.7 this, according to the manual, indicates a bad CVS file...
> 4.8 I deleted the CVS files from the c:/docs directories and tried to check
> out again -- no luck, get the same error msg.

Yes.  Now you've explicitly created the problem it was seeing
before; what I'm wondering in the preceding paragraphs is how
*else* the same situation (missing c:/docs/CVS subdirectory)
could have arisen.


|  | /\
|-_|/  >   Eric Siegerman, Toronto, Ont.        address@hidden
|  |  /
With sufficient thrust, pigs fly just fine. However, this is not
necessarily a good idea.
        - RFC 1925 (quoting an unnamed source)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]