[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Permission denied when using CVS remotely

From: Kris Thielemans
Subject: RE: Permission denied when using CVS remotely
Date: Mon, 4 Jun 2001 12:47:21 +0100


I upgraded to cvs 1.11, because that was what was lying around. This gave me
indeed a better error message:
$ cvs -t update
cvs update: notice: main loop with CVSROOT=pp4:/usr/local/cvsroot
 -> Starting server: rsh pp4 cvs server
cannot create_adm_p /tmp/cvs-serv24426/PPhead
Permission denied

So, Derek, yes, it was /tmp. But what should I do about it?

On my Linux server parapet, I get the following for ls -l /

drwxrwxrwt   10 root     root         4096 Jun  4 13:11 tmp/

(where apparently the t means 'sticky bit' saying that non-owners can't
delete  a file in that directory).

>From my client, I tried:

address@hidden ~/pp4/parapet
$ rsh parapet mkdir /tmp/testdir
address@hidden ~/pp4/parapet
$ rsh parapet touch /tmp/bla

This worked without problems, as shown by ls -l /tmp on parapet:
-rw-r--r--    1 kris     method          0 Jun  4 13:22 bla
drwxr-xr-x    2 kris     method       4096 Jun  4 13:22 testdir/

Any suggestions?


PS: I'm upgrading my server to 1.11.1p1 now. Don't think it will help

> From: dprice [mailto:dprice]On Behalf Of Derek R. Price
> Kris Thielemans wrote:
> > I've set -up CVS on our Linux system (SuSE 6.3,cvs 1.10.7). It all works
> > fine.
> > Now I'm trying to access the archive remotely. I try this from
> both a Sun
> > (solaris 2.7, cvs 1.10.7) and NT (4.0 sp5, using the cvs version 1.11
> > distributed with cygwin).
> >
> > I get "Permission Denied" error messages when I try certain
> things, while it
> These error messages are tough for me to interpret as well, but the /tmp
> directory would be my first suspicion.  Check your
> /usr/local/cvsroot[/module[/...]] and any LockDir you may have
> set as well.
> Upgrading your server to 1.11.1p1 (available from
> ) might
> help matters as well.  Many error messages have been improved and
> many bugs
> have been fixed in the year or two since 1.10.7 was current.
> Derek

reply via email to

[Prev in Thread] Current Thread [Next in Thread]