[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Help with CVSWeb

From: Alexander Kamilewicz
Subject: Help with CVSWeb
Date: Mon, 11 Jun 2001 13:18:45 -0500

Hello all,

I know this isn't CVS, per se, but an add-on, but I'm hoping, given the
amount of experience here, that some of you have installed cvsweb
successfully and can help me out.

The problem:  I'm trying to install cvsweb
(, and it won't show
anything below the initial cvs directory (see below for specifics).

What I did:

1.  Got the .tar.gz for version 1.93
2.  Running on a Netscape server, so I had the webops guys define the
cgi-bin & conf directories.
3.  Chucked cvsweb.cgi in cgi-bin, and cvsweb.conf into conf, and
"icons" into cgi-bin (more on this later, a small problem)
4.  Edited cvsweb.conf like so:

        'Repository' => '/usr/local/cvs',

# This tree is enabled by default when
# you enter the page
$cvstreedefault = 'Repository';

5.  Modified cvsweb.cgi like so:

$config = $ENV{'CVSWEB_CONFIG'} || '../conf/cvsweb.conf';

i.e. the conf file is up out of cgi-bin, and down into conf.

I also changed the path to my perl binary.

At this point I then tried to run the script.  It failed due to
"unspecified variables".

My local UNIX guru pointed out that using #!/usr/local/bin/perl -ws and
use strict; was what was causing the error, since a good # of the
variables are unspecified (duh).  So I took out -ws and commented out
use strict;.

Now it worked. gave the front page
I was looking for, with a listing of all of the modules (but no icons,
they appear to not be in the right place).

However, when I click on any module I get "page not found".  Now, there
are 2 pieces of diagnosis I've been able to find out from my subsequent

1.  When I try to click on some modules, the error log is "Could not
find X file or directory".  Other times the error is "couldn't exec
$modulename:  is a directory"

2.  With all cvsweb installations I've seen, the URL changes to when you click on a
file.  With mine, it changes to when I
click on directory "foo", for example.  What it should be doing it
changing to .  To further
complicate the problem, if I type in, it will show me the
proper page, i.e. the one I was expecting.  The problem seems to be in
the way cvsweb.cgi is being specified as the script to run.

So, any ideas?

Thanks in advance,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]