[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

(no subject)

From: root
Subject: (no subject)
Date: Mon, 13 Aug 2001 05:05:22 -0400

>From address@hidden  Fri Feb  2 05:27:41 2001
>Return-Path: <address@hidden>
Received: from ( [])
        by (8.9.3/8.9.3/Debian 8.9.3-21) with ESMTP id 
        for <address@hidden>; Fri, 2 Feb 2001 05:27:39 +0900
Received: from localhost ([]
        by with esmtp (Exim 3.16 #1 (Debian))
        id 14OQGz-0001bX-00; Thu, 01 Feb 2001 15:24:05 -0500
Received: from [] (
        by with esmtp (Exim 3.16 #1 (Debian))
        id 14OQEd-0001XK-00
        for <address@hidden>; Thu, 01 Feb 2001 15:21:39 -0500
Received: (from address@hidden)
        by (8.11.2/8.9.3) id f11KLZd14307;
        Thu, 1 Feb 2001 15:21:35 -0500 (EST)
X-Authentication-Warning: laine set sender to address@hidden 
using -f
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Message-ID: <address@hidden>
From: address@hidden (Laine Stump)
To: address@hidden (Laine Stump)
Cc: "Reinstein, Shlomo" <address@hidden>,
Subject: Re: Problems with CVS version 1.10.8 on Windows 2000
In-Reply-To: <address@hidden>
References: <address@hidden>
X-Mailer: VM 6.90 under Emacs 20.7.1
Reply-To: address@hidden (Laine Stump)
Sender: address@hidden
Errors-To: address@hidden
X-BeenThere: address@hidden
X-Mailman-Version: 2.0
Precedence: bulk
List-Help: <mailto:address@hidden>
List-Post: <mailto:address@hidden>
List-Subscribe: <>,
List-Id: Announcements and discussions for the CVS version control system 
List-Unsubscribe: <>,
List-Archive: <>
Date: Thu, 1 Feb 2001 15:21:34 -0500
Status: O
Content-Length: 2386
Lines: 50

> "Reinstein, Shlomo" <address@hidden> writes:
> > 
> >     cvs [checkout aborted]: CVSROOT z:/iil/iswp/data/apt/ISIS/repository
> > must be an absolute pathname

Laine Stump writes:
> I just looked at the code that generates this error message, and it
> looked to me like it shouldn't give you this problem - it's very
> straighforward parsing of the contents of CVSROOT, then examination of
> the first few characters of the directory (it compares *exactly* what
> is printed in the error message). Hmm... unless the binary you're using
> was somehow compiled with the *Unix* version of the function
> isabsolute() (or unless 1.10.8 has a bug in that function). Why don't
> you try getting a copy of 1.11? If you can't find it prebuilt, I can
> send you one that I built for NT.

I think I may know the answer to your problem. Are you using the cygwin
version of cvs.exe (the one built using the cygwin tools, and using
cygwin.dll)? I just tried that version of cvs and got *exactly* the same
error message as you. I'd bet that you were previously using a cvs.exe
built with Microsoft VC++, and are now using one built with gcc and
cygwin tools. It looks like the cygwin build ends up with the Unix
version of the function isabsolute(), rather than the Windows version.

You can either switch to a cvs.exe that was built using Microsoft's
compiler, or try using this as your cvsroot:


That is a path that will be understood by cygwin executables, and will
also pass the Unix isabsolute() function test.

(I just tried a similar CVSROOT with the cygwin cvs binary, and it not
only eliminated the "must be an absolute path", it also allowed a checkout
to complete correctly)

(A bit of background - the Unix version of isabsolute() just verifies
that the first character is "/"; the Windows version (in the windows-NT
subdirectory) checks that either the first character is "/" or "\", or
that the *2nd* character is ":" and the 3rd is "/" or "\".)

I at first considered sending a bug report about this, but on further
though - I believe this *is* the desired behavior, since most (all?) of
the cygwin tools don't recognize drive specifiers anyway - they expect a
unified filesystem.

Info-cvs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]