[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

(no subject)

From: root
Subject: (no subject)
Date: Mon, 13 Aug 2001 05:25:37 -0400

>From address@hidden  Tue Feb 13 19:17:58 2001
>Return-Path: <address@hidden>
Received: from (address@hidden [])
        by (8.9.3/8.9.3/Debian 8.9.3-21) with ESMTP id 
        for <address@hidden>; Tue, 13 Feb 2001 19:17:53 +0900
Received: from localhost ([]
        by with esmtp (Exim 3.16 #1 (Debian))
        id 14SaEu-000444-00; Tue, 13 Feb 2001 02:51:08 -0500
Received: from ([])
        by with esmtp (Exim 3.16 #1 (Debian))
        id 14SaBs-00040R-00
        for <address@hidden>; Tue, 13 Feb 2001 02:48:00 -0500
Received: from ( [] (may 
be forged))
        by (8.9.3/8.8.7) with ESMTP id 
        for <address@hidden>; Mon, 12 Feb 2001 23:49:43 -0800
Message-ID: <address@hidden>
From: Peter Ajamian <address@hidden>
X-Mailer: Mozilla 4.73 [en] (Win95; U)
X-Accept-Language: en
MIME-Version: 1.0
To: address@hidden
Subject: Can't get passwd to show up in CVSROOT & cvspwd
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Sender: address@hidden
Errors-To: address@hidden
X-BeenThere: address@hidden
X-Mailman-Version: 2.0
Precedence: bulk
List-Help: <mailto:address@hidden>
List-Post: <mailto:address@hidden>
List-Subscribe: <>,
List-Id: Announcements and discussions for the CVS version control system 
List-Unsubscribe: <>,
List-Archive: <>
Date: Mon, 12 Feb 2001 23:44:50 -0800
Status: O
Content-Length: 2636
Lines: 60

I previously posted this to the newsgroup with no
response.  After realizing that posts to this list goto the newsgroup,
but not vice-versa I decided to re-post to the list.

Original Post:

I've tried everything I can think of, and barring manually copying it
over to the repository, I cannot get the passwd file itself to show up
the CVSROOT directory.  The only thing that does show up is passwd,v. 
Unfortunately, pserver does not recognize changes in passwd,v, only
those in passwd itself.  If I manually copy the file over it works, but
when I make changes I have to copy it over manually again because cvs
apparently is not maintaining the file in the repository.  I'm not
having this problem with any other file in CVSROOT, only passwd.  What I
need to know is how can I get cvs to maintain the actual passwd file and
not just passwd,v in CVSROOT?


I decided to write a new cvspwd program after taking a look at the one
distributed by GlassFish Networking Interactive (the pre-compiled binary
seg-faulted on me and dumped core, and I got a void main() warning when
I tried to compile the source-code, after a cursory glance at the source
I decided it wasn't even worth the space it was taking up on my HDD).  I
thought I'd bring it up to gauge interest in the utility and possibly
see if there is already one out there that I missed.  Anyways, Following
is a list of features that I am implementing in my cvspwd utility...

Program is modeled after the standard Unix passwd program, with a
similar set of features.

Program allows individual users to change thier own passwords if they
can supply the old password, it allows root or repository owners
(privleged users) to change anyone's password without supplying the
original password.

Privleged users can add or remove CVS users with the program.

Privleged users can temporarily block access to users (this is
accomplished by appending an ! to the front of the users password,
thereby rendering it unusable).

The system username to assign new CVS users to can be set by either an
environment variable or a command line option, and the command line
option can be used to change a CVS user's system username by a
privledged user.  The environment variable makes it easy to have a
system username which is dedicated to the various different CVS users.

Salts are randomly generated instead of being fixed.

Other features (such as the ability to mark a user as read-only) are
planned for the future.

Regards, Peter

Info-cvs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]