[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

possible bug

From: Jeremy Finke
Subject: possible bug
Date: Mon, 20 Aug 2001 12:44:36 -0500


I have had an interesting problem, that I haven't been able to work
around...  Let me start off that I have tried several versions of cvs
including the newest snapshot (1.11, I believe), the one from, and the cvs version from last week sometime.

I have a new Solaris 8 installation.  I installed cvs on it.  I was not able
to checkout anything from my repository using pserver.  So, I tried a couple
of the graphical cvs programs... jCVS, javaCVS... SmartCVS...  They were all
able to work...  I could do a status and an update, however, with cvs once
one of the other programs checked something out.

So, I tried a couple of other things..  Along the way, I discovered that I
could checkout from repositories that weren't mine.  So, I could check out
mozilla and ccvs.  So, I decided to set up a couple of more repositories,
now wondering if it was my server.  Nope, still no go.  When I did a cvs co
<project>, it would just sit there and hang.  However, I did discover that I
could checkout from the local pserver.

So, James Youngman suggested I do a truss on cvs to see what it was doing.
When he looked at the results, he thought that it was not hitting the
network.  I later verified that with a sniffer.  However, it did hit the
network when I did an update or status, or even a login.

So, I decided, that since I can check things out from the internet, what if
I set up a repository on a totally seperate (private t1) network.  So, I set
that up..  It worked!!  

So, now I am wondering if cvs has an issue with my networking...  My
client's ip address is  My server's ip address is  That doesn't work...  So, I made a new test server.  It's
ip address is  That one does work...  Plus, I can check out
from anything from beyond my firewall...  So, I am wondering if cvs is
getting confused because of the class 
A network being split by a 24 bit subnetmask...  Is it misreading something
from the OS?  Because my linux boxes work just fine...

Any ideas??



reply via email to

[Prev in Thread] Current Thread [Next in Thread]