[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: commit problem win98 cygwin

From: Bishop, Murray
Subject: RE: commit problem win98 cygwin
Date: Mon, 27 Aug 2001 16:54:01 +1000

> From: Mike House [SMTP:address@hidden
> Sent: Sunday, August 26, 2001 3:11 PM
> I'm having trouble committing from my laptop to the
> repository on my desktop.
> I ran cvs init, and import from the laptop, checkout
> from both the laptop and the desktop, update from both
> the laptop and the desktop, but only commit works from
> the desktop, not the laptop. The following is from the
> laptop:
> Checking in clean.bat;
> //home1/files/cvsroot/sys5/work/clean.bat,v  <-- 
> clean.bat
> new revision: 1.3; previous revision: 1.2
> cvs [commit aborted]: cannot change mode for
> //home1/files/cvsroot/sys5/work/,cl
> ean.bat,: Permission denied
That "Permission denied" sounds to me like like a problem 
introduced by your use of a Windows file share (//home1/files 
I guess) to allow the laptop to get at files on desktop using 
:local: access.

You might find that the permission problem has been worked
round by the cvs ports for wincvs
or cvsnt (I'm only guessing. I don't know.)

Or that you are able to set up a client server CVS configuration.

> I suspect there is something wrong with
> /work/,clean.bat,
> seems like there is an extra ',' at the start of
> clean.bat, but I don't know how or why.
As far as I know, the ,clean.bat, is a filename used by CVS as
part of its normal operation on a file in the repository thats 
usually named clean.bat,v (except when CVS is operating on it).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]