[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS and password

From: Colin Bester
Subject: CVS and password
Date: Thu, 6 Sep 2001 10:36:31 -0500

I have my cvs server running on a linux box and am using pserver mode to
When I have the CVSROOT/config file set SystemAuth=yes then cvs -d
:pserver:address@hidden:/myrepos login works and I can log in using
username and the system password for username.

I then used passwd command to change the password to something else and
cut and paste the new password field into the CVSROOT/config file



I also set SystemAuth=no

And then did a commit on both config and passwd (after adding passwd).

When trying to log on I now get:
"no such user username in CVSROOT/passwd
cvs login: authorization failed: server rejected access to
/myrepos for user username"

If I view the passwd file directly under the CVSROOT directory then I
can see username.
I have also tried setting passwd file as:
as one would do for anonymous users, but same result.

At all times I used edit and commit to make changes to file.

Any suggestions

Colin Bester    address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]