[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Remote cvs access via SSH in KDevelop 1.4

From: Cihan Esen
Subject: Re: Remote cvs access via SSH in KDevelop 1.4
Date: Wed, 12 Sep 2001 08:33:48 -0700 (PDT)

Thanks for help, but i still couldn't solve my

First of all, my account on the server was already
configured to allow connection based on my ssh key.I
can do anything on cvs via ssh as long as i provide my
username and password each time i try to do something
on cvs.

I followed your advices. When i tried the command 

eval ssh-agent

linux printed 3 lines exactly as this

SSH_AUTH_SOCK=/tmp/ssh-XXXTMP3R/agent.1203; export
echo Agent pid 1204;

then i did the command


linux said

Could not open a connection to your authentication

then i used the command


and i saw that, the two environment variables that
"eval ssh-agent" command tried to set, was not set. I
set them manually via "export" as "eval ssh-agent"
command printed.After this when i commit "ssh-add"
command, it printed a line like this

Identity added: /home/myusername/.ssh/identity

but i still got the same message on KDEvelop as
before(I'd given the message on my previous e-mail).It
seems as if KDevevelop still couldn't make the server
to resolve my username and password. For instance, i
thought that when i open an ssh-agent whenever i try
to make an ssh connection on console to the server it
won't ask me username and password but it did.

After many many tries and looking to several manuals i
still couldn't find a way out.I would really really
appreacite a little more help on this.


--- Simon Hausmann <address@hidden> wrote:
> On Tue, Sep 11, 2001 at 02:14:36AM -0700, cihan esen
> wrote:
> > Hi everyone,
> >  
> > when i try to "commit" in cvs in KDevelop 1.4 i
> get a
> > message like this
> > 
> > "You have no controlling tty.Cannot read
> Passphrase"
> > 
> > our cvs repository is configured to accept remote
> > connections via SSH, i can do any changes in
> > repository if i try to access it in linux
> > console(providing the username and password) but i
> > couldn't achieve this in KDevelop platform. In
> linux
> > console before any actions i try to make in cvs,
> cvs
> > asks me the password and username, but KDevelop
> does
> > not, and gives me the above message.
> What you could to to fix this and gain additionaly
> convenience is
> to make use of the ssh agent.
> Change your account on the remove server to allow
> authentication
> based on a ssh key (add your public (and password
> protected) key 
> to ~/.ssh/authorized_keys on the remote machine) .
> Then on the client machine you start the ssh-agent
> with
>  eval `ssh-agent`
> Followed by a 'ssh-add' (with a key other than the
> default identity
> as argument, if you want) . That will require you to
> type your password
> for that key, once. From the terminal you just
> started the ssh agent
> you now start kdevelop/cervisia or whatever and you
> should be able to
> use CVS over SSH without explicity password
> authentication (the authentication
> still takes places, but it's done in the background
> by the ssh agent process) .
> Simon

Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger

reply via email to

[Prev in Thread] Current Thread [Next in Thread]