[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

tty allocation of ssh

From: Cihan Esen
Subject: tty allocation of ssh
Date: Thu, 13 Sep 2001 06:41:00 -0700 (PDT)

Hi, i still couldn't solve the error, (i'm suffering this when i try to do 
something on
cvs with an ssh connection to the cvs server, there is on problem when i try to 
do this
on linux console, but i couldn't do anything on cvs on XWindow)
"You have no controlling tty. Cannot read passphrase"

After some suggestions, i ran "eval ssh-agent", set the required 
variables, then ran
"ssh-add" with a result as "Identity added.." and so on.

Problem didn't dissappeared. I ran "ps x", and i saw that in the tty 
column of ssh-agent
process there is a "?". Shouldn't it be a tty?

By the way, my /dev/tty attributes are all set to 0666 and ssh_config 
and sshd_config
files in client and server are configured properly. 

Any suggestions?


Terrorist Attacks on U.S. - How can you help?
Donate cash, emergency relief information

reply via email to

[Prev in Thread] Current Thread [Next in Thread]