[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cvswrappers question

From: David Carson
Subject: Re: cvswrappers question
Date: 14 Sep 2001 11:15:03 -0700

"Prabhu Ram (InfoSpace Inc)" <address@hidden> wrote in message 
> We are running CVS 1.11 and I am trying to turn off auto-merge for certain
> types of files (which happen to be text files say ending with .xyz).
> According to documentation it appears that cvswrappers is the way to do
> this.  So I make the following entry in the cvswrappers file in CVSROOT
> *.[xX][yY][zZ]        -m  COPY 
> also tried
> *.[xX][yY][zZ]        -m  'COPY'
> In either case, I still get MERGE behavior rather than COPY behavior.  What
> am I missing ?

I am struggling with the same thing.  I have tried every method I know
about to prevent merging:

o  $CVSROOT/CVSROOT/cvswrappers
o  ~/.cvswrappers
o  <dir_to_file>/.cvswrappers
o  cvs update -W "-m COPY"

None of them seems to do anything at all.  

This leads me to believe I have misunderstood the meaning of the COPY
option. Here is the situation: The file in question is text, not
binary, but it gets modified during a build.  That means that when the
file is committed by another user _and_ I have done a build on my
machine (modifying it locally), the next time I update I will get a
conflict.  What I DO NOT WANT is the conflict markers (<<, >>) with
the conflict information.  This produces a file that will cause my
build to fail!  I can live with either:

o  move the local copy to .#whatever and bring down the repository
o  complain that no merge is possible and do nothing

but cannot live with the attempted merge.  

The -m COPY should prevent any kind of merge (successful or
conflicting), right? Have I misunderstood the purpose of -m COPY?  Is
this something I need to setup before I do an import?  What's the


reply via email to

[Prev in Thread] Current Thread [Next in Thread]