[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: The krb5.h blues

From: Jonah Tsai
Subject: Re: The krb5.h blues
Date: Mon, 17 Sep 2001 17:07:29 -0400
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20010131 Netscape6/6.01

From: "Ayers, Mike" <address@hidden> <mailto:address@hidden>
To: "'address@hidden'" <mailto:&apos;address@hidden&apos;> <address@hidden> 
Subject: The krb5.h blues
Date: Mon, 17 Sep 2001 12:50:11 -0500

        I'm trying to install 1.11.1p1 onto a Solaris8 system.  It seems
that no matter how I configure it, I get the krb5.h not found problem in
server.c.  I've tried configuring --without-gssapi, but that didn't help.
Is there any way around this?


/|/|ike /+yers

1. Solaris 8, by default, does not come with Kerberos 5 include files and development libraries, although they were in Solaris 7. Solaris 8 does come with some krb5 runtime libraries. I am not able to find any of the krb5 dev libraries from Sun's website, nor is any question regarding these files posted on comp.os.sun.admin got answered. 2. If you need KDC, etc, you'd need to download a copy of Sun's SEAM package. This has a nice GUI replacement, gkadmin, for kadmin. 3. The way I get it to compile on Solaris 8 is to download a copy of MIT's Kerberos 5, install it in /usr/local/ and then compile CVS with kerberos on. I used gcc for the compilation though. I have not tried using SparcWork for doing this.

You will probably want to use --with-krb4=<...> and --with-gss-api=yes --enable-encryption flags, if a kerbeoized CVS is what you're aiming for. These flags will get you a kerberoized CVS with "gserver" in client/server mode.

Jonah Tsai

reply via email to

[Prev in Thread] Current Thread [Next in Thread]