[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

NewbeeQ: WinCVS & CVS server on Red Hat 7.2 box

From: Sigurður Reynisson
Subject: NewbeeQ: WinCVS & CVS server on Red Hat 7.2 box
Date: Fri, 30 Nov 2001 00:40:14 -0000


I'm new to CVS/WinCVS so pls bear with me ;)

I keep getting the "classic" (*blush*)
"Cannot access /home/cvsroot/CVSROOT
Permission denied"
from WinCVS when I log in with a regular user id
and try to do an Import or a Checkout.

When I log in as cvsroot all is well, ie. I can Import,
Checkout and Commit.

"cvs init" runs without any errors.

My setup is:

- WinCVS 1.2/Netbeans 3.2.1 on Win2k

- CVS (1.11.1p1) on Red Hat 7.2 (xinetd)
  (out of the box install)

- CVSHOME=/home/cvsroot (put that in manually)

- output from "ll -las" in CVSHOME
total 16
   4 drwx------    4 cvsroot  cvsroot      4096 Nov 29 22:44 .
   4 drwxr-xr-x    8 root     root         4096 Nov 29 21:26 ..
   0 -rw-r--r--    1 cvsroot  cvs             0 Nov 29 22:17 .cvspass
   4 drwxrwxr-x    3 root     root         4096 Nov 29 22:36 CVSROOT
   4 drwxrwxr-x    7 cvsroot  cvs          4096 Nov 29 22:44 examples

I have tried to set "chown cvsroot.cvs -R CVSROOT" with same results.
Also tried running "cvs init" as reguser and cvsroot.

- reguser is linked to cvs as (this I did manually using vim):
passwd entry:cvsroot:x:505:198::/home/cvsroot:/bin/bash
group  entry:cvs:x:198:cvsroot,reguser

(cvsroot is a user and cvs a group, no user defined for cvs that is)
and I've tried to define groups for the modules (groupname=modulename)
and put cvsroot and reguser in them.

When I start WinCVS I get:
CVSROOT: address@hidden:/home/cvsroot (password authentication)
is that correct? (I'm using authentication: "passwd" file on
the cvs server, I did "touch .cvspass" in CVSHOME)

- cat /etc/xinetd.d/cvspserver:
service cvspserver
        socket_type     =       stream
        protocol        =       tcp
        wait            =       no
        user            =       root
        server          =       /usr/bin/env
        server_args     =       -i cvs -f --allow-root=/home/cvsroot pserver

This cvspserver file is "out of the box". If I skip the "-i cvs" the server
does not listen on the cvs port.

I can telnet cvs port (as in the trouble shooter), besides, I can login
both as reguser and cvsroot.

I tried to set the HOME variable in /etc/rc.d/init.d/xinetd to /, but
xinetd seems to handle this, the start section contains:

I've read lot's in the mail archive, cvs faq, trouble shooter etc,
all to no avail. I must be overlooking something very simple here,
I'm beginning to feel...

Do I just use cvsroot for everything?

Am I not supposed to use regular Linux users with CVS?

Any hints or help welcome pls, Thx.

I now this is your typical FAQ material, but I've had
no luck with it. Sorry for bugging you with this!

remove all three x's for email

reply via email to

[Prev in Thread] Current Thread [Next in Thread]