[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: - problems with labels

From: laine+vss2cvs
Subject: Re: - problems with labels
Date: 04 Dec 2001 16:33:37 -0500
User-agent: Gnus/5.0808 (Gnus v5.8.8) Emacs/20.7

Eric Johanson <address@hidden> writes:

> I've been working on importing a large VSS tree into CVS.   (Using
>  Anyway, It's looking like it's upset with the "Labels" on
> the tree.  In both cases where it's gotten upset, it's been a label that
> looks like a date:
> can't parse timestamp Label: "v020201"
> -or-
> can't parse timestamp Label: "Daily-04.09.2001"
> So, I've been reviewing the code for vss2cvs.... Inside of sub
> resync_file, it's looking at the data coming from vss... Then it calls: "
> ($user,$timestamp) = parse_user_and_timestamp($_);"   So I'm guessing that
> it's looking for a user & timestamp.  The part I don't get is, why it's
> trying to get this from the label, as I would not expect it to look for a
> username from the label.... :/

VSS attaches a userid to each label when it is created, and uses the
same line format for both labels and new revisions.  VSS2CVS,
similarly, sends both types of lines through the same parser.

Of course you are right that this is totally unnecessary, since CVS
keeps neither userid nor timestamp with its labels. (The code worked
that way when I got it, and since it worked, I didn't mess with it!

> Here is where it finally dies, right at the start of
> parse_user_and_timestamp():
> #
> # For U.S. format dates: mm/dd/yy, time as hh:mm[am or pm indicator]
> #
>     die "can't parse timestamp $_"
> unless(address@hidden:[\s]*([^\s]+)\s+Date:\s+(\d+)/(\d+)/(\d+)\s+Time:\s+(\d+):(\d+)([ap])@);
>     my ($user, $mo, $day, $yr, $hr, $min, $sec) = ($1, $2, $3, $4, $5, $6,
> 0);
> # Version: $Id:,v 1.12 2001/02/24 17:18:27 laine Exp $
>  - -It looks like I'm running version 1.12; is there I newer version
> around?

There is a 1.14 available. It does have a change to that regexp to
allow VSS userid's with embedded spaces (and replaces those spaces
with "_" in CVS) - could that be your problem?

You can get the latest vss2cvs at:

I'm currently having DNS problems (my primary DNS was run by a friend
whose system got taken out by the @home shutdown :-(, and the updates
to my records at the NIC haven't yet been propogated everywhere), so if the 
above doesn't work, try this:

>   I found some postings with problems with it running under a
> cygwin shell; I think I've fixed those; I'd be happy to submit a patch...

Sure! Always glad to get improvements! Send them to me and I'll do my
best to put them in (as long as they don't break working with the
native Windows build of CVS). It may be a day or two before mail to starts working again, so don't be surprised if you get a
bounce or two.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]