[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Solved : local CVS issue on a Win- 98 platform

From: address@hidden
Subject: Solved : local CVS issue on a Win- 98 platform
Date: Wed, 5 Dec 2001 11:04:23 +0100

  Dear Sirs,

According to the bug submission I have sent to you on november 23, here is a 
work-around that works fine on Windows-98.

I extracted the source code of CVS1.11 and looked into the src/lock.c file as 
well as comments in the winnt directory. The problem I mentioned is quite 

I develop freewares on my PC. I operate a dial-up connection to the Net to get 
my mail and surf from time to time. No "hostname" is then permanently defined. 
I have read comments in the C source code : CVS may get into trouble if no 
permanent net is attached on Windows.

The src/lock.c file expects the "hostname" to create a temporary lock name. On 
my PC, it can not usually findany network (PPP down) and the hostname is not 

The src/lock.c file already provides the workaround. This file should be 
recompiled with the option "HAVE_LONG_FILE_NAME" undefined. The code will then 
skip the "hostname" field.

CVS now works fine on my standalone Win-98 platform.

Yours sincerely,

Laurent MARIE

Annex : original mail bug report

  Dear Sir,

I have been using CVS for more than 2 years on UNIX, LINUX and Windows-NT.

I am trying to operate a local CVS on my new Windows-98 PC and I face up a new 
problem I never noticed on any other plateform :
I can not checkout any directory because CVS cannot create the read lock in the 
repository !

I first initiated a CVS repository (cvs init) and imported a few files (cvs 
import). I cannot checkout the imported directory nor the CVSROOT 
administrative directory. Both checkout fail on the read lock. I did exactly 
the same thing on NT and it worked fine !

I tried to checkout the directory called "filtre" :

cvs -t checkout filtre
-> main loop with CVSROOT=c:\users\devs\repos
-> Create_Admin (., filtre, c:\users\devs\repos/filtre, , , 0, 0)
-> unlink(./CVS/Tag)
-> fopen(c:\users\devs\repos/CVSROOT/history,a)
-> unlink(./CVS/Entries.Static)
CVS.EXE checkout: Updating filtre
CVS.EXE checkout: cannot create read lock in repository 
`c:\users\devs\repos/filtre': No such file or directory
CVS.EXE [checkout aborted]: read lock failed - giving up

ls -Ra filtre
. .. CVS

. .. Entries Entries.Log Repository Root

the "filtre" directoy is created as well as the CVS but no file is checked out.

Is there any known bug of local CVS for Windows 98 (cvs 1.11.1p) ?
Is there any dedicated environment variable to be set for Windows 98 ?
Is there any issue in the naming of the read lock for Windows 98 ?

I still hear from you.

Yours sincerely,

Laurent MARIE

Faites un voeu et puis Voila !
Avec Voila Mail, consultez vos e-mails sur votre mobile Wap.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]